[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Lilypond miscompiled on Fedora 17

From: Pavel Roskin
Subject: Lilypond miscompiled on Fedora 17
Date: Wed, 02 May 2012 22:06:34 -0400
User-agent: Internet Messaging Program (IMP) H3 (4.1.4)


I mentioned in passing that Fedora 17 (currently in beta) ships Lilypond 2.15.29 that reports bogus bar checks.

It turns out that both the current Lilypond from git and Lilypond 2.14.2 are miscompiled on the up-to-date Fedora 17 so they exhibit the same problem.

That's the minimal example. It doesn't report a bar check, but it shows an error:

\version "2.14.2"
\score {
    \new Staff { b2 }
    \new Staff { b1 }
  \layout {}

$ lilypond
GNU LilyPond 2.15.38
Processing `'
Interpreting music...
programming error: moving backwards in time
continuing, cross fingers
Preprocessing graphical objects...
Finding the ideal number of pages...
Fitting music on 1 page...
Drawing systems...
Layout output to `'...
Converting to `./barcheck.pdf'...
Success: compilation successfully completed

Attached is the output converted to png format.

Lilypond 2.14.2 reports the same error.

I tried compiling Lilypond with compat-gcc (version 3.4), but it doesn't understand some compiler flags needed by Python.

Pavel Roskin

Attachment: barcheck.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]