[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: git push doesn't work

From: David Kastrup
Subject: Re: git push doesn't work
Date: Fri, 27 Jul 2012 12:28:14 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.1.50 (gnu/linux)

Marc Hohl <address@hidden> writes:

> After Trevor's mail, I found out that I already *had*
> .ssh/config|id_rsa| etc.
> due to some ssh connections to other servers a friend of mine created for me
> (I was sitting next to him, but apparently he can type commands faster
> than I
> could think, so I didn't understand what he was doing. Within seconds,
> he established
> some secure connections to servers, and I never cared about this).
> So I copied the contents of into the right place on the
> savanna web site,
> and got a mail that it is accepted. Fine.
> I changed the .git/config file again to match the description:
> url = ssh://<username>
> (well, I inserted my *real* username in the line above!)

Your username on Savannah, not on your local host, right?

> and tried the ssh connection with
> git pull --verbose
> but after two hours or so, I still get
> Permission denied (publickey).
> fatal: The remote end hung up unexpectedly
> I don't understand what's wrong here.

Try calling

ssh -v -v <username>

This won't ever get you in (because you are not allowed to execute a
normal shell), but it should fail in more informative ways.

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]