[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: git push doesn't work

From: Marc Hohl
Subject: Re: git push doesn't work
Date: Fri, 27 Jul 2012 12:35:31 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120714 Thunderbird/14.0

Am 27.07.2012 12:28, schrieb David Kastrup:
Marc Hohl <address@hidden> writes:

After Trevor's mail, I found out that I already *had*
.ssh/config|id_rsa| etc.
due to some ssh connections to other servers a friend of mine created for me
(I was sitting next to him, but apparently he can type commands faster
than I
could think, so I didn't understand what he was doing. Within seconds,
he established
some secure connections to servers, and I never cared about this).

So I copied the contents of into the right place on the
savanna web site,
and got a mail that it is accepted. Fine.

I changed the .git/config file again to match the description:

url = ssh://<username>

(well, I inserted my *real* username in the line above!)
Your username on Savannah, not on your local host, right?

and tried the ssh connection with

git pull --verbose

but after two hours or so, I still get
Permission denied (publickey).
fatal: The remote end hung up unexpectedly

I don't understand what's wrong here.
Try calling

ssh -v -v <username>

This won't ever get you in (because you are not allowed to execute a
normal shell), but it should fail in more informative ways.
OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /home/marc/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
ssh: Could not resolve hostname Name or service not known

Hmmmm, in an earlier mail I wrote that
The authenticity of host ' (' can't be established.
RSA key fingerprint is 80:5a:b0:0c:ec:93:66:29:49:7e:04:2b:fd:ba:2c:d5.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ',' (RSA) to the list of known hosts.
Permission denied (publickey).

So at least is a known host, I assume.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]