[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lilypond-2.18.2/lilypond-from-gitRepo gets muddy with help2man

From: lux-integ
Subject: lilypond-2.18.2/lilypond-from-gitRepo gets muddy with help2man
Date: Tue, 29 Apr 2014 18:22:58 +0100
User-agent: KMail/1.13.5 (Linux/3.1.4nbfARAID; KDE/4.4.5; x86_64; ; )


I am new to this list. .  I tried the lilypond-users-list  but a half-response 
led me to surmise perhaps I should try here

I am attempting to compile  both lilypond-2.18.2  and the (unstable) lilypond-
from-git  on a  computer with these:-
--cpu  -amd64 3 cores
--os - linux BLFS(pure 64bit) linux-3.10.37, gcc-4.8.1 guile-1.8.8, help2man, 
dblatex3.2,ghostscript-9.06 (and other reqs to compile  lilypond )

I ran configure successfully (in both instances ) like so:-

cd lilypond-XXXX
mkdir build
cd build
--options  ....

Then attempted to compile by running make like so:-

make all

However  'make all'  (in both instances )    ends like so:-
/home/linteg/lilypond-2.18.2{ or 
lilypondOutOfGit}/build/scripts/build/out/help2man out/lilypond > 
help2man: can't get `--help' info from out/lilypond
Try `--no-discard-stderr' if option outputs to stderr
make[1]: *** [out/lilypond.1] Error 127

The  build-failure messages above are totally muddy and opaque to me; I 
have'nt a clue what they  mean  nor how to   get the lilypond-build  to pass  
this glitch .

I also tried  to build  within the source tree  (i.e. without the mkdir build 
&& cd build ) before I ran configure  and the same make-failure  results.

Help/advice would be greately appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]