[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUB and mpfr/mpc

From: David Kastrup
Subject: Re: GUB and mpfr/mpc
Date: Wed, 26 Nov 2014 16:10:24 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

Masamichi HOSODA <address@hidden> writes:

>> Masamichi HOSODA <address@hidden> writes:
>>> In mingw, lilypond crashes as follows. 
>>> Does someone know this reason? 
>>> ```
>>> C:\tmp\lilypond-2.19.16-0.mingw\$_OUTDIR\usr\bin>type
>>> { c d e f g a b }
>>> C:\tmp\lilypond-2.19.16-0.mingw\$_OUTDIR\usr\bin>lilypond
>>> GNU LilyPond 2.19.16
>>> Processing `'
>>> Parsing...
>>> warning: no \version statement found, please add
>>> \version "2.19.16"
>>> for future compatibility
>>> Interpreting music...
>>> Preprocessing graphical objects...terminate called after throwing an 
>>> instance of
>>>  'std::bad_alloc'
>>>   what():  std::bad_alloc
>> No idea.  Looks like out of memory.
> I also think so.
> I look at the task manager.
> The memory that lilypond.exe uses is increased rapidly.
> Then, lilypond.exe crashes at about 2 GB.
> My Windows environment is 64-bit. The memory is quite larger than 2 GB.
> I think that something continues demanding a memory by an infinite loop.
> Then, lilyond.exe crashes, when the 32-bit process memory limit is exceeded.

My guess would have been that garbage collection is broken on the
platform, but even without collecting garbage, I should think that 2GB
should be sufficient for getting a small file like that compiled.

>>> Converting to `./test.pdf'...
>>> warning: `(gs -q -dSAFER -dDEVICEWIDTHPOINTS=595.28
>>> -dDEVICEHEIGHTPOINTS=841.89 -dCompatibilityLevel=1.4 -dNOPAUSE
>>> -dBATCH -r1200 -sDEVICE=pdfwrite -sOutputFile=./test.pdf
>>> -c.setpdfwrite' failed (139)
>>> fatal error: failed files: ""
>> That's a SIGSEGV.  Not something that a GhostScript executable should be
>> throwing.  Could it be that the 64-bit cross compilation causes
>> problems?
> I tried on 32-bit FreeBSD.
> The result was just similar.
> I tried to execute gs directly.
> Then Segmentation fault (core dumped) happened.
> linux-x86 binary that I built seems no problem.
> I think that it's no problem even if 32-bit binary
> is cross compiled by the 64-bit environment.

No idea.  Phil, what is your experience with that?

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]