[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to use git-cl

From: Carl Sorensen
Subject: Re: Unable to use git-cl
Date: Tue, 8 Mar 2016 18:54:35 +0000
User-agent: Microsoft-MacOutlook/

On 3/8/16 4:03 AM, "James Lowe" <address@hidden> wrote:

>On 07/03/16 17:35, Carl Sorensen wrote:
>> On 3/7/16 12:50 AM, "address@hidden on behalf of Valentin
>> Villenave" <address@hidden on behalf of address@hidden>
>> wrote:
>>> On Mon, Mar 7, 2016 at 3:21 AM, Carl Sorensen
>>> wrote:
>>>> It appears that my ssl certificate is not working properly.
>>> Greetings Carl,
>>> have you by any chance disabled JavaScript in your Web browser? (I was
>>> unable to post anything until I complied with SourceForge demanding to
>>> execute non-free JavaScript code in my browser.)
>>> When issuing git cl upload, does the actual page open in your Web
>>> browser? Does it tell you that everything is ok or does it complain
>>> about something?
>> I will check.  I got a window opening up in my browser, but I think it
>> a codereview window not a sourceforge  window.
>Yes that is correct.
>> Not knowing how it is
>> supposed to work, I don't know what to look for.
>All I can say is that if I am not logged into Rietveld at the time I run
>git-cl I get a 'Google' login window. When I log in, or if I am already
>logged in the Browser will show a single line about 'Authentication
>completed' (or somesuch words), then in the terminal, you can see that
>the upload process (to Rietveld) goes through its process - displaying
>what it is doing - and then once that has completed I get the prompt
>from git-cl asking about which sourceforge issue to update (it does some
>simple detection on trying to guess the issue number it thinks - git-cl
>that is - should update). You apply the appropriate answer and that is it.

I have gotten that far -- I give the appropriate answer to the issue
number, and then I get a whole slew of error messages, as posted earlier.

At this point, I have spent several hours trying to make this process
work, and I am getting very frustrated.   I can find no documentation
about how to troubleshoot my issues.  All I can find is a set of commands
to copy and paste, which I have tried multiple times.

I would hate to leave LilyPond development, but it appears that I have no
choice, as I cannot contribute with a broken toolchain.

I can upload patches to Rietveld, as you can see at

but the links to the issue tracker never get made.

As far as I can see, we have a custom git-cl, so I can't get general help
anywhere but on the devel list.

I would appreciate anybody who can point me in a direction that I can
troubleshoot my problem.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]