[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Solved: make doc fails after updating dev to VERSION 2.19.38 (and later)

From: Villum Sejersen
Subject: Solved: make doc fails after updating dev to VERSION 2.19.38 (and later)
Date: Thu, 17 Mar 2016 10:03:43 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Icedove/38.6.0

On 16-03-2016 22:58, Carl Sorensen wrote:

LilyPond can be very finicky trying to get a clean build.  That's why we 
recommend using LilyDev.

Thanks for that advice, though it is way beyond my skill and needs. I
never build anything else than current master, but have tried doing so
even back in .svn-times.

I realize this is not a great answer for a Linux hacker.

I am not a hacker, not a programmer. ;) 25 years ago i - with help - was
a system administrator on a Sun OS 1.4.x system...

I am a bit embarassed that core developers find using their time on
questions I might have answered myself.

Many thanks to James, you and all the many other helping hands.

I've looked briefly through your logs.  Are you running a multi-processor
build (make -j3 doc)?  If so, that can make it harder to interpret the
logs.  It might be well to to a single job build (make doc).

My ancient pc is an AMD Athlon X2, so only -j2 was used. Building docs
locally takes nearly two hours. I prefer it that way because my internet
connection is slow (but reliable).

I'm sorry I don't have a better answer for you at this time.

Well, it made me try again several times :)

It think it worked out the third time after trying various combinations
of, configure, make clean, make distclean and make doc-clean.
Exactly how and why must here be an unanswered question...


med venlig hilsen
Villum Sejersen
Nørregade  1 A
DK-4500  Nykøbing Sjælland
mobil   +45   30 34  03 44

reply via email to

[Prev in Thread] Current Thread [Next in Thread]