[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fun with upgrades - not

From: Federico Bruni
Subject: Re: Fun with upgrades - not
Date: Tue, 28 Jun 2016 18:49:56 +0200

On Tue, Jun 28, 2016 at 4:50 PM, Phil Holmes <address@hidden> wrote:
Last week I decided to bite the bullet and upgrade from Ubuntu 10.04 to a more recent version. I downloaded an upgrade to 12.04, and then used that to do an online upgrade to 14.04. As a result of this, I lost most of the applications needed to build LilyPond. I've grabbed a number of then with
the software installer or apt, but gave that up for a while whilst I
needed the machine for another purpose.

I would first try to set up the system and avoid virtual machines for LilyPond development.
Installing the dependencies should be as easy as:

sudo apt-get build-dep lilypond

If/When something breaks, you might consider the virtual machine.

This was to run a Windows 7 VM - I use this with Adobe Lightroom 6 (which won't run on my Vista desktop) for editing my photos. So I installed the
latest Oracle VirtualBox and discovered that 14.04 mounts its disks in
media/username, meaning that VB could not find the image of my VM.  I
hacked the set up file by hand, and got the VM running. Problem is, it
runs like a complete drain, taking about two minutes to move between
photos. The VM on 10.04 was instantaneous. No idea why this should be,
but I got so p**sed of with it that I've ordered a new PC just for my

I would have tried another virtual machine (libvirt and virt-viewer work great) and/or another guest.

By the way, do you know Darktable?

I think that it's very similar to Lightroom, but it's open source and runs on Linux and Mac.
It works very well and it's actively developed.

So I'm back to thinking about what to do with the Linux installation. An option would be to start from scratch with the latest version of LilyDev.
My concern is how this would mount my two non-system disks: a 2TB hard
drive and an SSD. With 14.04, if I access my SSD from my "patchy" user,
my mail "phil" uer can't see the drive since it seems to mount at

I don't understand clearly what's your setup, but at work I'm using Samba to share folders between Linux guest and Windows 7 host.

I'm also not sure how I would best go about GUB builds.
Previously I had a 64 bit Ubuntu 12.04 VM running on the 10.04 machine
from a "gub" user. Not sure whether it would be best to save the VM image and try to transfer it to the new build, or forget about it and start from
scratch again.  Also not sure whether GUB will run OK just on the base
LilyDev build, rather than in a VM? I'm concerned that if Windows is so slow on a VM on 14.04, perhaps the GUB Linux will have the same problem?

I've never tried running GUB, so LilyDev doesn't support it. And GUB requires python2.4, right?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]