[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Changing voice order...

From: David Kastrup
Subject: Re: Changing voice order...
Date: Thu, 27 Oct 2016 15:54:04 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (gnu/linux)

Werner LEMBERG <address@hidden> writes:

>>>This concerns << ... \\ ... \\ ... ... >>
>>>If we have more than one voice, voices are assigned in order:
>>>1/2, 1/2/3, 1/2/3/4, 1/2/3/4/5, 1/2/3/4/5/6 ...
>>>while the documentation is quite explicit that, ordered from top to
>>>bottom, assignments should be more like
>>>1/2, 3/1/2, 3/1/2/4, 5/3/1/2/4, 5/3/1/2/4/6 ...
>>>namely keeping the small voice numbers for the inner voices.  Now I
>>>am sort of afraid that changing this is likely to end pretty
>>>disruptive to existing scores.  Even though I don't know how many
>>>really use the original ordering unchanged as well as intentionally.
>> I just stumbled over this for the first time recently (because I
>> usually use the othe construct with explicit voices). I found it
>> disturbing that I can't define the voices from top to bottom but
>> have to apply a seemingly wrong ordering.
> I think we must not change the original commands.  However, we could
> introduce another series of commands that do the numbering from top to
> bottom.  A possibility would be \voice + roman numeral: \voiceI,
> \voiceII, \voiceIII, etc.  Or what about \voice.1, \voice.2, ...?

Werner, that does not even make sense.  The reason \voiceOne
... \voiceTwo need to be the inner voices is because they have the
smallest shifts and those need to be in the middle in order to let up-
and downstem heads not move apart ridiculously far when they are usually
close in pitch.  There is a reason you have to use \voiceOne/\voiceTwo
from the middle.

But that wasn't even the question.  The question was not about the
meaning of \voiceOne ... \voiceFour but about which of those commands to
use where in << \\ \\ \\ >> constructs.  Currently they are applied as
<< \context Voice = "1" \with \voiceOne ...
   \context Voice = "2" \with \voiceTwo ...
   \context Voice = "3" \with \voiceThree ...
   \context Voice = "4" \with \voiceFour ...

and the proposal was to make this

<< \context Voice = "1" \with \voiceThree ...
   \context Voice = "2" \with \voiceOne ...
   \context Voice = "3" \with \voiceTwo ...
   \context Voice = "4" \with \voiceFour ...

(I haven't actually stated that I was going for keeping the names of the
Voice contexts but that appears to make the most sense).

It may be argued that we'd rather want
\voiceUp \voiceDown \voiceUpUp \voiceDownDown instead of
\voiceOne \voiceTwo \voiceThree \voiceFour
then.  Because of reasons.  I'm sympathetic to proposals along that line
(better names welcome) but we'd still want to keep the current ones as
aliases I should think.

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]