[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile-2.0 and debian

From: Urs Liska
Subject: Re: guile-2.0 and debian
Date: Wed, 7 Dec 2016 10:28:35 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Icedove/45.4.0

Am 07.12.2016 um 09:53 schrieb Federico Bruni:
> Il giorno mer 7 dic 2016 alle 8:42, Urs Liska <address@hidden> ha
> scritto:
>>>  In case you don't know already, last news about guile2 and debian:
>> Just for the record (although it's probably evident):
>> This doesn't only mean one can't install "lilypond" from Debian testing
>> but it's also not possible to do
>> # apt-get build-dep lilypond
> I discovered it just yesterday.
>> So is there a way to get LilyPond's build-dependencies on that distro
>> (either a list of dependencies to install manually or by pinning it to
>> an older release?
> You can find a list here (change it to a one line so you can paste it
> on a terminal):

OK, thank you.
After installing these building LilyPond fails with the following error:

WARNING: Please consider installing optional programs or files:  URW++
OTF fonts (download OTF files from
and put them under '~/.local/share/fonts' etc., or use
--with-urwotf-dir) guile extractpdfmark (Optionally using Ghostscript >=
9.20 together with Extract PDFmark can significantly reduce the disk
space required for building the documentation and the final PDF files.)

ERROR: Please install required programs:  guile-config (guile-devel,
guile-dev or libguile-dev package) libguile (libguile-dev, guile-devel
or guile-dev package). GUILE-with-rational-bugfix Python.h
(python-devel, python-dev or libpython-dev package) pkg-config makeinfo
texi2html texi2pdf texindex

So it seems I'll be at the same stage as before because there won't be a
guile 1.8 available ...

Seems I traded running Frescobaldi for not being able to build LilyPond
anymore ...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]