[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile-2.0 and debian

From: Federico Bruni
Subject: Re: guile-2.0 and debian
Date: Wed, 07 Dec 2016 11:34:57 +0100

Il giorno mer 7 dic 2016 alle 10:28, Urs Liska <address@hidden> ha scritto:
OK, thank you.
After installing these building LilyPond fails with the following error:

WARNING: Please consider installing optional programs or files:  URW++
OTF fonts (download OTF files from
and put them under '~/.local/share/fonts' etc., or use
--with-urwotf-dir) guile extractpdfmark (Optionally using Ghostscript >=
9.20 together with Extract PDFmark can significantly reduce the disk
space required for building the documentation and the final PDF files.)

ERROR: Please install required programs:  guile-config (guile-devel,
guile-dev or libguile-dev package) libguile (libguile-dev, guile-devel
or guile-dev package). GUILE-with-rational-bugfix Python.h
(python-devel, python-dev or libpython-dev package) pkg-config makeinfo
texi2html texi2pdf texindex

So it seems I'll be at the same stage as before because there won't be a
guile 1.8 available ...

Sorry, I should have told you to install guile-1.8-dev instead of guile-2.0-dev (now the default in LilyDev, as we want other people to test the work on guile2 migration). In that list there is texi2html, so I'm surprised that it seems not installed in your system. Try to install it again.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]