[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: linux-ppc harfbuzz GUB build error

From: Hans Aikema
Subject: Re: linux-ppc harfbuzz GUB build error
Date: Sun, 11 Dec 2016 16:44:40 +0100

> On 11 Dec 2016, at 15:54, Masamichi Hosoda <address@hidden> wrote:
>> I hope someone can shed a light on what I’m doing wrong here.
>> librestrict:error:/home/gub/gub/target/linux-ppc/root/usr/cross/libexec/gcc/powerpc-linux/4.9.4/cc1plus:
>>  tried to open () file /usr/include/stdc-predef.h
>> librestrict:allowed:
>>  /home/gub/gub/target/linux-ppc
>>  /tmp
>>  /dev/null
>>  /dev/urandom
>>  /proc/self
>> <command-line>:0:0: internal compiler error: Aborted
>> Full harfbuzz.log attached
> My GUB environments are Ubuntu 14.04 LTS 64 bit and Ubuntu 16.04 LTS 64bit.
> I have never used GUB on CentOS.
> But, your log file has the following line.
> /home/gub/gub/target/linux-ppc/src/harfbuzz-1.3.0/configure: line 7264: 
> /usr/bin/file: No such file or directory
> Does your system have /usr/bin/file ?
> My system has it and my log file does not have that line.

/usr/bin/file was indeed not yet present on my system. Added it to the mix and 
retrying a build.

Meanwhile took a look on the rest of the logfile and spotted a bunch of 
“checking <….>… no”… any of those a concern in your experience?

checking for powerpc-linux-dlltool... no
checking for dlltool... no
checking for sysroot... no
checking for powerpc-linux-mt... no
checking for mt... no
checking if : is a manifest tool... no
checking if powerpc-linux-gcc  supports -fno-rtti -fno-exceptions... no
checking whether -lc should be explicitly linked in... no
checking whether to build static libraries... no
checking for gtk-doc... no
checking for gtkdoc-check... no
checking for gtkdoc-check... no
checking for gtkdoc-rebase... no
checking for gtkdoc-mkpdf... no
checking whether to build gtk-doc documentation... no
checking for native Win32... no
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking if more special flags are required for pthreads... no
checking for PTHREAD_PRIO_INHERIT... no
checking for FONTCONFIG... no
checking for ICU... no
checking for powerpc-linux-icu-config... no


The official requirements for building:

* You need
  - about 9 GB of free space (for all platforms)
  - standard unix shell utilities: cat, cp, install, mv, rm, sed, ...
  - a standard unix development environment with GCC and G++
  - Python 2.4 or newer (2.5, 2.6, 3.0 are known to work)

are rather vague (on points 2 and 3) and in a Dockerized linux env you usually 
have the bare minimum available and all else needs to be added. Hence the 
/usr/bin/file was missing on my system. On a regular CentOS I assume it 
would’ve been present.

Thanks for looking into it…. will keep trying (and will look closer to 
log-files before errors start appearing when I run into trouble as there might 
be more obvious items missing that are present in a regular base linux install)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]