[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LilyDev 5.0 released

From: Federico Bruni
Subject: Re: LilyDev 5.0 released
Date: Fri, 20 Jan 2017 06:31:28 +0100

Il giorno ven 20 gen 2017 alle 2:16, Paul <address@hidden> ha scritto:
Hi Federico,

On 01/19/2017 06:35 AM, Federico Bruni wrote:
If you have some time, can you try installing another Debian testing iso? Choose the netinst ISO for your architecture here:

This would help to understand if the problem is in LilyDev or in Debian. I guess it's the latter. Probably some hardware/kernel problem. I'm just guessing, I never experienced these problems.

Well, this is probably good and bad news, but I tried the netinst Debian testing iso (i386 with LXDE) and it's working fine. (Oddly enough it works both with and without PAE/NX enabled.)

Maybe I'll use this as an opportunity to try setting up all the dev dependencies from scratch?

This is what I'd recommend. If you managed to get the VM working...

I tried installing LilyDev5 on my old mac laptop. It installs fine, and I can boot into LXQT, entering my password, but then there seems to be some problem with the mouse/keyboard integration as I can't get it to respond to clicks or key presses after I have logged in.

This is a problem of Virtual Box. I'm afraid that you should ask for help on Virtual Box forums.

I installed it on this old laptop just to see if it would work, but it is too old and slow to be of any real use.


virt-manager logs:

A. When installing virt-manager and dependencies via synaptic package manager:

W: Can't drop privileges for downloading as file '/root/.synaptic/tmp//tmp_sh' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

Ah, thanks.

Unable to connect to libvirt.

Verify that:
 - The 'libvirt-bin' package is installed

$ aptitude show libvirt-bin

Synaptic package manager shows that it's installed. (I tried that command but I don't have aptitude installed.)


 - The 'libvirtd' daemon has been started

$ systemctl status libvirtd

Looks like I did manage to get this started, as confirmed by this command.

- You are member of the 'libvirtd' group

$ groups

Looks like there is no libvirtd group.  So that's probably it.

I see that 16.04 is Yakkety, so according to the guide below you should add your user to libvirt. You can do it with this command:

$ sudo adduser $USER libvirt

Then exit the session, log in again and check that it is now present:

$ groups

Have you verified these points?
IIRC you are quite new to Linux and use Ubuntu in your host machine, right? Which version?
Yes, still pretty new at it.  Ubuntu 16.04 is my host machine.

Read this guide:

In later versions of libvirt the correct group is libvirt (instead of libvirtd). That's the case for Fedora25, libvirt version 2.2.0.

Thanks for the tips and all your work on LilyDev! At this point I may just stick with VirtualBox rather than try to get up to speed with libvirt (assuming things go well with this new debian vm).

I realize now that I may have suggested a simpler command to check if Virtual Box is the problem or not. Please try running this in a terminal:

kvm -cdrom lilydev-bla-bla.iso -boot d -m 2048

reply via email to

[Prev in Thread] Current Thread [Next in Thread]