[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help with building LilyPond

From: Winston, Charles R.
Subject: Help with building LilyPond
Date: Sun, 14 May 2017 16:21:38 +0000

Hi LilyPond Developers!

First off, let me introduce myself. My name is Charles Winston, and I’m 
participating in the Google Summer of Code this year, working on improving the 
internal representation of chords, with mentor Carl Sorenson. I’ve just 
finished finals and so now I am really excited to get much more familiar with 
LilyPond and its community in this period of community bonding.

I am having some trouble setting things up, specifically with building 
LilyPond. I‘ve installed LilyDev and downloaded the source code using lily-git 
successfully (I’ve been following the instructions on the LilyPond 
Contributor’s Guide). However, when I try to prepare to build LilyPond using 
the commands:

sh --noconfigure
mkdir -p build/
cd build/

I get the error:

WARNING: Please consider installing optional programs or files:  URW++ OTF 
fonts (download OTF files from 
 and put them under '~/.local/share/fonts' etc., or use --with-urwotf-dir) 
guile-2.0 < 1.9.0 (installed: 2.0.13) extractpdfmark (Optionally using 
Ghostscript >= 9.20 together with Extract PDFmark can significantly reduce the 
disk space required for building the documentation and the final PDF files.)

ERROR: Please install required programs:  guile-config < 1.9.0 (installed: 
2.0.13) (guile-devel, guile-dev or libguile-dev package) libguile 
(libguile-dev, guile-devel or guile-dev package). GUILE-with-rational-bugfix

See INSTALL.txt for more information on how to build LilyPond

It seems like I’m missing some files? The proper version of guile-config and 
libguile. Where can I get these?

Thanks for the help,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]