[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LilyDevOS, a LilyDev container + full VM image

From: Paul
Subject: Re: LilyDevOS, a LilyDev container + full VM image
Date: Fri, 21 Jul 2017 14:29:00 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.2.1

On 07/17/2017 04:58 AM, Federico Bruni wrote:

$ sudo systemd-nspawn -bD lilydevos-0.1
sudo: unable to resolve host t440s

This is not causing any problem, right?
Anyway, here you can find some hints on how to fix it:

Thanks, I've seen this for awhile, but everything has seemed to work fine. I've now fixed it with the info in that link. (My machine name in /etc/hosts was off.)

Spawning container lilydevos-0.1 on /home/paul/lilypond-world/LilyDevOS/lilydevos-0.1.
Press ^] three times within 1s to kill container.
Failed to create directory /home/paul/lilypond-world/LilyDevOS/lilydevos-0.1/sys/fs/selinux: Read-only file system Failed to create directory /home/paul/lilypond-world/LilyDevOS/lilydevos-0.1/sys/fs/selinux: Read-only file system

I think you can safely ignore it.

This may happen when selinux is disabled, according to this:

But I have selinux disabled and I'm not getting those messages...

# sestatus
SELinux status:                 disabled

Huh, odd.  I'll just ignore it for now.

[gitk] can work also from the guest if you use the correct DISPLAY environment variable.
Find it in your host with this command:

$ echo $DISPLAY

Then launch gitk from the container with:

$ DISPLAY=:0 gitk

You can use an alias and forget the special command.
Add this line to ~/.bashrc:

# Let gitk work on host display
alias gitk="DISPLAY=:0 gitk"

As .bashrc is the same for container and full VM, I won't add this configuration. I'll add only a suggestion in the README.

Great!  This is working for me now.  Same display value of `:0`

I've now updated the instructions about the container.

I've also added instructions on setting up the virtual machine in libvirt (i.e. also GNOME Boxes and virt-manager) with a single command.

Looks good.  Nice additions about libvirt use.

A suggestion: it might be worth clarifying the steps for first setup vs repeat use of the container? I think the main (only?) difference is that you don't need to run the setup script after you've already done it.

Also, the authentication in git-cl opens a web page in a browser so I'm not sure how that will work from the container?

w3m and elinks accept cookies by default, so login to google is easy and saved across different sessions.

I just need to check if the redirect from /get-access-token?port=8001 works.

I want to avoid installing a regular browser, as it would add some dependencies and increase the final size of the container.

Cool, glad there's a good solution for this.

BTW, let me know if the password is working. I'm not sure I've uploaded the correct version..

It wasn't working for me (e.g. when I tried to install guile-devel).

If it doesn't, use this command as root:

 echo 'dev:lilypond'|chpasswd

This fixed it for me. And I was able to install guile-devel. (GNU Guile 2.0.14)

Thanks again.  It's coming together well!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]