[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling lilypond in debian stretch with self-compiled guile-1.8

From: Federico Bruni
Subject: Re: compiling lilypond in debian stretch with self-compiled guile-1.8
Date: Mon, 23 Oct 2017 19:07:19 +0200

Il giorno lun 23 ott 2017 alle 18:34, Federico Bruni <address@hidden> ha scritto:

Il giorno ven 20 ott 2017 alle 21:52, David Kastrup <address@hidden> ha scritto:
Federico Bruni <address@hidden> writes:

 I have my own Guile 1.8 libraries.  I use something like

GUILE_CONFIG=/usr/local/tmp/guile-1.8/bin/guile-config ./configure

I got the same problem. However, this appears to be because avoiding the check for guile-config in this manner appears to _also_ disable
 check (and any useful default) for Guile.  So I have to do

 GUILE=/usr/bin/guile GUILE_CONFIG=... ./configure ...

 to get this working smoothly.  /usr/bin/guile happens to be a
provided by Ubuntu. It's fine since it is used for the scripts which
 run ok under Guile-2.0.

 This did not help, unfortunately. I keep getting the same error.

 Now I've removed guile-2.0.
I've built and installed guile-1.8 in /usr/local. /usr/local/bin is
 in my path.

 But I get this error:

 checking for guile-config... no

If your configure script is _checking_ for guile-config, you don't have

Ok, I thought that it was not necessary as I have now, after removing guile-2, only one guile-config in my PATH. I found out that there's another requirement needed: running ldconfig after guile-1.8 installation.

Actually, I ran `sudo ldconfig`, right after building guile, in a postinst script while building a debian container. I started the container, launched the configure in lilypond source and got the usual error:

checking guile compile flags... /usr/local/bin/guile: error while loading shared libraries: cannot open shared object file: No such file or directory

So I ran `sudo ldconfig` and then the configure, which was now successful.
Do you know why?

For the records, these are the commands that worked well to build and install guile-1.8 system wide on debian stretch:

git clone
cd guile
git checkout branch_release-1-8
./configure --disable-error-on-warning --prefix=/usr/local
sudo make install
sudo ldconfig

echo "GUILE_CONFIG=/usr/local/bin/guile-config" >> ~/.bashrc

lilypond-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]