[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Terminology of baseMoment, beats, groups

From: David Kastrup
Subject: Re: Terminology of baseMoment, beats, groups
Date: Sat, 11 Nov 2017 21:23:50 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

Urs Liska <address@hidden> writes:

> Am 11.11.2017 um 15:30 schrieb Carl Sorensen:
>> When I look at , the thing that we
>> call a beat in the c++ code is what openmusictheory calls a pulse.  And
>> what we call a beat group is what they call a beat.  In this context,
>> baseMoment is the length of a pulse.  And beatStructure defines the
>> lengths of each beat in the measure in pulses.  It would be a
>> straightforward first step to replace "beat" with "pulse", and "beat
>> group" with "beat" in both the c++ and scm code.
> While I've never heard that term in this context I agree that pulse
> and beat are good names for the things in question, and I suggest to
> rename them in the code (while it shouldn't change anything in the
> user-facing syntax). However, I wouldn't actually do that as an
> independent patch but in the context of a more general reworking.

We don't really want code documentation and user documentation

That being said, I find "pulse" distinctly awkward, but my vote against
it (as common terminology for both programmers and users) is to be
considered a user vote, not a maintainer veto.

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]