[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.20 plans.

From: Phil Holmes
Subject: Re: 2.20 plans.
Date: Tue, 16 Oct 2018 17:25:10 +0100

----- Original Message ----- From: "David Kastrup" <address@hidden>
To: <address@hidden>
Sent: Monday, October 08, 2018 4:35 PM
Subject: 2.20 plans.


I don't think there is much of a point in delaying more.  I've recently
made another run through patches that should be in 2.20 and pushed to
stable/2.20 branch.

I think further integration work is as likely to destabilize as to
stabilize stuff (if I not already did so), so the plan is to have
a) let Phil release 2.19.83 as soon as he wants
b) release 2.20.0 from that state (with a few cherry-picks on top) about
a week after the last urgent "stop the presses" call.  Those would
involve synching up documentation and bug fixes so obviously important
that one would rather see them in than give them some time for testing.

This will be followed (as soon as the state of download/web pages and
Phil's resources permit) with releasing 2.21.0 to get an unstable
version to refer to.

David Kastrup

I've been trying a GUB build today. It's failed rather strangely. At first I got:

Command barfed: cd /home/gub/NewGub/gub/downloads/lilypond/git && git fetch git:// stable/2.20:refs/heads/

Tail of log/gub.log >>>>>>>>
*** Stage: download (lilypond, darwin-x86)
invoking cd /home/gub/NewGub/gub/downloads/lilypond/git && git fetch git:// stable/2.20:refs/heads/ fatal: Unable to look up (port 9418) (Name or service not known) Command barfed: cd /home/gub/NewGub/gub/downloads/lilypond/git && git fetch git:// stable/2.20:refs/heads/

I thought that might be down to a network problem, so I tried the network and it looked OK so I ran the make again and this time I got:

Tail of target/freebsd-x86/log/lilypond.log >>>>>>>>
building package: freebsd-x86::lilypond
*** Stage: download (lilypond, freebsd-x86)
*** Stage: untar (lilypond, freebsd-x86)
invoking cd /home/gub/NewGub/gub/downloads/lilypond/git && git fetch git:// stable/2.20:refs/heads/
<<<<<<<< Tail of target/freebsd-x86/log/lilypond.log

Traceback (most recent call last):
File "bin/gub", line 233, in exceptional_build
build (settings, options, files)
File "bin/gub", line 229, in build
b.build_source_packages (names)
File "bin/../gub/", line 334, in build_source_packages
self.spec_build (spec_name)
File "bin/../gub/", line 262, in spec_build
deferred_runner.execute_deferred_commands ()
File "bin/../gub/", line 167, in execute_deferred_commands
cmd.execute (self.logger)
File "bin/../gub/", line 48, in execute
buildspec.source.update_workdir (buildspec.expand ('%(srcdir)s'))
File "bin/../gub/", line 699, in update_workdir
self._update_workdir_shallow (destdir)
File "bin/../gub/", line 707, in _update_workdir_shallow
NameError: global name 'barf' is not defined

Any thoughts of where to go from here?

Phil Holmes

reply via email to

[Prev in Thread] Current Thread [Next in Thread]