[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUB lilypond build fails

From: Phil Holmes
Subject: Re: GUB lilypond build fails
Date: Sat, 29 Dec 2018 20:17:53 -0000

----- Original Message ----- From: "Werner LEMBERG" <address@hidden>
To: <address@hidden>
Cc: <address@hidden>; <address@hidden>
Sent: Monday, December 24, 2018 9:39 PM
Subject: Re: GUB lilypond build fails

It may be of note that an earlier (i.e. 6 months' earlier)
successful run doesn't have the "invoking GS" line in its output.

What does

 locate merge-rests-engraver

say?  Are files containing this name actually present for the old
version?  And what about newer version?  Maybe a log file was created
that contains more information?


It now failes with a different file not found, but essentially still the same:

invoking gs -sDEVICE=png16m -dGraphicsAlphaBits=4 -dTextAlphaBits=4 -slilypond-datadir=v2.19.64-1/share/lilypond/current -r101 -dAutoRotatePages=/None -dPrinted=false -sOutputFile=/home/gubd/GubDir/gub/uploads/webtest/v2.21.0-1/compare-v2.19.64-1/v2.19.64-1/rest-positioning.png -dNOSAFER -dEPSCrop -q -dNOPAUSE v2.19.64-1/rest-positioning.eps -c quit
Traceback (most recent call last):
File "/home/gubd/GubDir/gub/target/linux-x86/src/", line 1358, in ?
main ()

If I try to locate the file we get:

locate rest-positioning.eps

A curious other problem which I'd not remarked on before is that a little higher in the output I get:

Operand stack:
(/home/gub/NewGub/gub/target/linux-x86/root/usr/share/lilypond/current/fonts/otf/emmentaler-20.otf) (r)
Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1983 1 3 %oparray_pop 1982 1 3 %oparray_pop --nostringval-- 1966 1 3 %oparray_pop 1852 1 3 %oparray_pop --nostringval-- %errorexec_pop .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval--
Dictionary stack:
--dict:1213/1684(ro)(G)-- --dict:0/20(G)-- --dict:82/200(L)--
Current allocation mode is local
Last OS error: No such file or directory
Current file position is 518
GPL Ghostscript 9.21: Unrecoverable error, exit code 1

When I was building from git master (just a lily build, not GUB) I had the same error until I nuked the build directory and started from scratch. Hmm.

Phil Holmes

reply via email to

[Prev in Thread] Current Thread [Next in Thread]