[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make check is broken (again) - patch testing seeming to taking more

From: Dan Eble
Subject: Re: make check is broken (again) - patch testing seeming to taking more of my time than I like
Date: Mon, 28 Oct 2019 09:37:18 -0400

On Oct 28, 2019, at 05:32, Werner LEMBERG <address@hidden> wrote:
>  Last OS error: No such file or directory
> because the `share' tree present in
>  gub/uploads/webtest/v2.21.0-1-unpack/v2.19.83-1/
> is not created by the script in
>  gub/uploads/webtest/v2.21.0-1-unpack/v2.21.0-1/
> I seem to remember that this has worked the last time I worked on gub
> (in January) …

My change that made 'share' a symlink seems a likely candidate, but I hope we 
can avoid simply reverting that, lest it require everyone to wipe their build 
directories and rebuild from scratch to avoid weird side effects.  I took pains 
to keep "make check" working with older baselines across that change, but I put 
no effort (or thought) into supporting a move back to the past.

I will attempt to build gub to reproduce and diagnose this issue.  If you think 
my time would be better spent preparing a patch that cleanly undoes the 'share' 
change, I'm open to hearing it.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]