[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Looking for help in configuring LilyDev in VirtualBox

From: Peter Toye
Subject: Re: Looking for help in configuring LilyDev in VirtualBox
Date: Wed, 22 Jan 2020 13:03:37 +0000

Wednesday, January 22, 2020, 6:43:48 AM, Michael Käppler wrote:

> Am 21.01.2020 um 20:44 schrieb Peter Toye:
>> Re: Looking for help in configuring LilyDev in VirtualBox
>> This time after the reboot I got the same result. No sharing of
>> clipboard, no more processes. Tried closing VBox and restarting it,
>> but same result.
> Try to start the client manually and see what happens:
> /usr/bin/VBoxClient --clipboard

>> There's one slight oddity: often (but not always) when booting the
>> LilyDev guest I get an error message - a bit too long to copy the text
>> so here's a screenshot:
>> I don't know if it's significant. It doesn't change the clipboard
>> behaviour.
>  From time to time, this happens on my machine, too.
> I thought it would be a problem specific to my
> combination of VirtualBox
> version / host os
> and guest os, but if you encounter the same problem it could be a
> general issue.

It's not important as long as it's not significant. I thought it might be 
affecting the boot process.

>> It's possible that my hamfisted attempts to install LilyDev as a guest
>> without all the instructions has screwed something up. I could start
>> again tomorrow using the instructions you sent me and see if it makes
>> any difference.
> Yes, I would suggest that you start from scratch again.

I made a new guest machine using your instructions. There are a few issues 
Step 3: the file names are LilyDev-1-debian-vm and the raw fle is .iso not .raw

Step11: I got an error from the command:
[dev@LilyDev:~]$ sudo dpkg-reconfigure keyboard-layout
[sudo] password for dev: 
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog based 
frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/ line 
debconf: falling back to frontend: Readline
dpkg-query: package 'keyboard-layout' is not installed and no information is 
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: keyboard-layout is not installed

So I used the mechanism in the current CG Step 8 to change the keyboard - 
probably a better idea and more user-friendly. Unless, of course, the clipboard 
is working.

After all that I tried your idea of starting the clipboard manually - it 
worked!! Or I'd never have managed to get the above text right :)

So the basic question is: why isn't it starting up? I used to be a Solaris 
sysadmin, but that ended 20 years ago and my copy of Frisch is long gone.

> Best regards,
> Michael

Best regards,



reply via email to

[Prev in Thread] Current Thread [Next in Thread]