[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ancient convert rules

From: Jean Abou Samra
Subject: Re: ancient convert rules
Date: Sun, 30 Aug 2020 17:19:21 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.10.0

Hi Jonas,

Le 30/08/2020 à 15:38, Jonas Hahnfeld a écrit :
For, I've been
looking at python/ and wonder if we really need all
ancient rules starting from version 0.1.9. Right now, a majority of
these won't even apply because Python 3 is much pickier about bad
escape codes in the regular expressions. Example:
     re.sub('\\musicalpitch', '\\pitch', s)
is wrong because \\ only escapes for the string and neither \m nor \p
are correct escapes in a regular expression. For this case, it's easy
to fix with raw strings and I think I was able to resolve most errors
so that all rules are able to run, but I've no way to guarantee that my
edits are correct.

Ah, we were doing overlapping work, thanks for letting us know! I'll let
you go ahead.

On 30/08/2020 14:38, Jonas Hahnfeld wrote:
To make the story short: Can we maybe instead drop any rules older than
2.12.0? Its last minor release 2.12.3 is more than 10 years ago.

I don't know.

While it is more than 10 years ago, I seem to recall a lot of stuff on Mutopia where there are LP files to use are from much older than 2010.

A quick searchin Mutopia's repository reveals that the oldest \version statement there is 2.4.0. That release dates back to 2004. I think it would be fine to drop
rules prior to that version, or maybe 2.0.

I think at the very least we should perhaps 'flag' anything (either as a warning or as an error) for users that might have needed to convert something that we have removed because of backward compatibility if they tried to use such a convert-ly file. Rather than look like it has worked until they try to compile it with the later code and then get an error and open a bug report (if you see what I mean).

It should be made to error out when conversion from a version older that 2.4.0 or
whatever is attempted, I guess. Does that address your concern?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]