[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make all fails (help2man cannot find info for lilypond because lilyp

From: Aaron Hill
Subject: Re: make all fails (help2man cannot find info for lilypond because lilypond cannot find
Date: Sun, 14 Nov 2021 06:59:33 -0800
User-agent: Roundcube Webmail/1.4.9

On 2021-11-14 2:04 am, Han-Wen Nienhuys wrote:
On Sun, Nov 14, 2021 at 7:03 AM Aaron Hill <> wrote:
NOTE: Manually specifying the library path...

/lib/x86_64-linux-gnu/ \
   --library-path /opt/guile-1.8/lib/ \
   out/bin/lilypond --version and reports "GNU LilyPond 2.23.5 (running Guile 1.8)".  As
such, the build process seems to be pretty close to working. But by the
time help2man needs to run, the library path information is lost.

have you tried setting LD_LIBRARY_PATH to the directory containing the
.so for the locally built guile?

Thanks, Han-Wen. It looks like the email I tried to send about an hour after my other one did not make it through. In it, I would have mentioned that I was able to get 'make all' to finish precisely as you have recommended. I had read a little more about LD_LIBRARY_PATH and found that on Ubuntu /etc/ is apparently the recommended way. I created an entry there for my custom guile 1.8 build and ran 'sudo ldconfig'. Initially I was concerned about making such a "global" change, but it appears that the release builds of lilypond continue to use their own bundled libraries.

But that raises a question: How is it the lilypond executables that ship with the .sh installation scripts do not need anything special with regards to libraries? When I ldd them, they appear to have a baked-in path to the libs that ship with lilypond. Is that something special that is done when preparing a release?

-- Aaron Hill

reply via email to

[Prev in Thread] Current Thread [Next in Thread]