[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Binaries of LilyPond 2.23.5 with Guile 2.2

From: Jonas Hahnfeld
Subject: Re: Binaries of LilyPond 2.23.5 with Guile 2.2
Date: Mon, 06 Dec 2021 20:47:32 +0100
User-agent: Evolution 3.42.1

Am Sonntag, dem 05.12.2021 um 23:09 +0100 schrieb Michael Käppler:
> Am 03.12.2021 um 19:17 schrieb Jonas Hahnfeld via Discussions on
> LilyPond development:
> Under Windows 10 x64, even the simplest file
> ```
> \version "2.23.5"
> { c4 }
> ```
> crashes with
> ;;; note: source file
> D:/Lilypond-generic/2.23.5-hahnjo/lilypond-2.23.5/share/guile/2.2/ice-9/eval.scm
> ;;;       newer than compiled
> D:/Lilypond-generic/2.23.5-hahnjo/lilypond-2.23.5/lib/guile/2.2/ccache/ice-9/eval.go
> ERROR: In procedure apply-smob/1:
> Wrong number of arguments to #<boot-closure 58d9ca0 (_ . _)>

Hm, I had this issue in the past, but thought I had solved it. Can you
check the modification dates on the .scm and .go files? The compiled
.go files must be newer, or Guile will try to recompile which may be
completely impossible for eval.scm.

How did you extract the archive? I tried both the Windows Explorer
"Extract All..." and 7zip. Is there another popular program that I
don't know, after not using Windows in years?


Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]