[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Lilypond suddenly stopped working for me.

From: Ryan M. Rifkin
Subject: Lilypond suddenly stopped working for me.
Date: Mon, 3 Dec 2001 18:43:14 -0500

I was running lilypond (ly2dvi) bunches of times, it was working fine.
Somehow, it stopped working.  I don't think I changed anything.
Whenever I try to run it now, on a known good file, I get the
following error:

bash-2.03$ ly2dvi
Running LilyPond...
lilypond: error while loading shared libraries: cannot open 
shared object file: No such file or directory
error: lilypond: command exited with value 32512
Traceback (innermost last):
  File "/usr/local/bin/ly2dvi", line 782, in ?
    run_lilypond (files, outbase, dep_prefix)
  File "/usr/local/bin/ly2dvi", line 390, in run_lilypond
    system ('lilypond %s %s ' % (opts, fs))
  File "/usr/local/bin/ly2dvi", line 314, in system
    error (msg)
  File "/usr/local/bin/ly2dvi", line 207, in error
    raise _ ("Exiting ... ")
Exiting ... 

I am running redhat 7.1, with lilypond 1.4.6.
guile IS installed on the machine:

bash-2.03$ guile -v
Guile 1.3.4
Copyright (c) 1995, 1996, 1997 Free Software Foundation
Guile may be distributed under the terms of the GNU General Public Licence;
certain other uses are permitted as well.  For details, see the file
`COPYING', which is included in the Guile distribution.
There is no warranty, to the extent permitted by law.

My general procedure (that worked before), was to run bash, then
source the shell script that was placed in
buildscripts/out/lilypond-profile where I compiled.

Any suggestions are appreciated.  I am trying to finish a final
project for a class, so I hope I can get it working again.  I already
tried rebooting the machine.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]