[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lilypond does a bit better

From: Jan Nieuwenhuizen
Subject: Re: lilypond does a bit better
Date: 05 Jan 2002 18:27:39 +0100

"Robert F. mudde" <address@hidden> writes:
[cc'd to lilypond-user]

> Dear Jan (or can we use Dutch?)

[we could, but I very much want to keep this on the list; it may
 be helpful to others; you may get help from others].

> thanks for your quick response. Indeed the space in the dir-name seems to be
> part of the problem. I can remove it by hand (and replace it by a directory
> robmudde).


> If I start lylipond via its icon it recreates the directory "rob
> mudde" with the space. I don't know how to get rid of that.

That's probably because your login is or was "Rob Mudde" and now that
string is probably in /etc/profile.  There's probably (I don't run
cygwin) something like:

    HOME="Rob Mudde"
    if [ ! -d $HOME ]; then
        mkdir  $HOME

You can fix that with a text editor.

> But I just go into the new directory /home/robmudde and remake the
> file. Subsequently, I run
> ly2dvi -P foo
> now it works better: the list of errors is much shorter.

Hmm, I guess that's good.

> It seems to me,
> that LilyPond is running fine. Nevertheless,  the same errors occur when
> invoking latex. No matter how many times I run ly2dvi, the same messages
> appear. They are listed below. Do you have any clue? perhaps you need to
> know that I have already latex running on my PC. It is stored in
> c:\tex\bin\win32 etcetera. This latex program is used by me as the
> text-editor for my job.

Ah, then that's where the problem is.  This could get a little bit
tricky.  What kind of TeX and version are you using?

> error: latex: command exited with value 256

LaTeX gets invoked by ly2dvi, through a wrapper script:


This script changes some environment variables (where to find the
fonts, font sources, font metrics) from POSIX to DOS-style.

There could be, and probably are, two problems: the latex command is
not in your $PATH, or the fonts cannot be found.

So, make sure that latex.exe is in your $PATH:

    $ echo $PATH   # show the path
    $ PATH="$PATH:/cygdrive/c/tex/bin/win32"  # append latex.exe dir to path
    $ latex.exe --version   # try if latex is there; don't forget .exe

but make sure /usr/lilypond/wrappers is earlier in the path.

Also, you should setup the texmf tree so that it matches the
environment variables.  Do something like:

    $ rm -rf /usr/share/texmf   # remove partial texmf tree
    $ ln -s /cygdrive/c/tex/texmf /usr/share/texmf   # create symlink

Of course, you should check all /cygdrive/c/... paths I used.  The
texmf tree is where the directories `web2c', `fonts' and `metafont'
are.  After you make the symlink, you should be able to do this:

    $ ls /usr/share/texmf/web2c/fonts/tfm/public/cm/cmr10.tfm  # command

and see:

    /usr/share/texmf/fonts/tfm/public/cm/cmr10.tfm    # output

If you're not short on diskspace, and have a good internet connection,
you may want to try the experimental tetex/texmf packages from:

It's using a fully cygwin based tex setup, which is more robust for
use with this cygwin based LilyPond; but you may experience other


Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter       |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]