[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lilypond still problematic

From: Jan Nieuwenhuizen
Subject: Re: lilypond still problematic
Date: 05 Jan 2002 21:14:13 +0100

"Robert F. mudde" <address@hidden> writes:

> I have edited /etc/profile. It had no line HOME="   ", but instead I found
> USER="`id -un`"
> so I added directly after this lin
> HOME="c:/cygwin/home/robmudde"
> and this seems to work: if I now start the icon, I found myself in this
> directory.

Ok, good.

> I have added PATH="$PATH:/cygdrive/c/tex/bin/win32". If I now typ echo $PATH
> it gives back:
> /usr/lilypond-1.4.9.uu1/wrappers:/usr/lilypond/wrappers:/usr/lilypond-1.4.9.
> uu1/
> bin:/usr/lilypond/bin::/usr/windows/MiKTeX/miktex/bin:/usr/windows/Ghostgum/
> GSvi
> ew:/usr/windows/gs/gs6.50/bin:/usr/local/bin:/usr/bin:/bin:/cygdrive/c/TEX/b
> in/w
> in32:/cygdrive/c/TeX/bin/win32:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/COMMA
> ND:/
> cygdrive/c/PROGRA~1/ULTRAE~1:/cygdrive/c/gstools/gs5.50/:/cygdrive/c/TeX/Ima
> gick
> It looks like TEX is now twice in the path.

Ok, fine.

> The response to latex.exe --version is:
> MiKTeX-TeX 1.24 (TeX 3.14159) (MiKTeX 2)
> Copyright (C) 1982 by D. E. Knuth; all rights are reserved.
> TeX is a trademark of the American Mathematical Society.

Hope that's ok.  We only tested with miktex-2.0...

> I tried
> $ rm -rf /usr/share/texmf
> but that didn't work. So I tried $ rm -r  /usr/share/texmf  which worked.


> next I typed
> $ ln -s /cygdrive/c/tex/texmf /usr/share/texmf
> which seemed ok.

But it wasn't ok, as we see below.  The /cygdrive/c/tex/texmf part,
should be the miktex directory that holds the texmf tree, ie, the
directories `web2c', `fonts' and `metafont'.  Maybe it's
/cygdrive/c/tex, I can't see from here.  Just try

   $ ls /cygdrive/c/tex

or so, or

   $ find /cygdrive/c/tex -name metafont

to find the right directory.  Remove the /usr/share/texmf symlink, and
recreate it again, this time to the right place, so that the ls
.. cmr10.tfm works.

> Next you wrote, that I should check all /cygdrive/c/... paths that you use.
> Well here you got me: I have no idea what to do.
> I found the directory web2c: it is address is
> c:\cygwin\usr\windows\MikTex\web2c. So, it is not were I expected it as your
> line

Hmm.  That's the directory shipped with LilyPond's miktex.  Maybe your
miktex-1.2 doesn't have a web2c directory.  And there's also
LilyPond's miktex on your system, after all.

In any case, you need to get this to work:

> $ ls /usr/share/texmf/web2c/fonts/tfm/public/cm/cmr10.tfm
> does NOT give
> /usr/share/texmf/fonts/tfm/public/cm/cmr10.tfm

Must be off now,

Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter       |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]