[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: David Bobroff
Subject: beam_control
Date: Thu, 23 May 2002 12:41:34 +0000


After trying out Lilypond a long time ago I recently decided it was time to
try it again.  I run a RH7.1 box so I downloaded the RPMs for RH7.1
(1.4-7).  The RPMs installed without any problems.  I then made a small
test.  Lily digested it just fine but the music fonts did not appear.  The
font files were in /usr/somethingorother so I linked them to where teTeX
looks for font material, ran 'texhash' and all was well.

Now I have run into a couple of problems which I have not been able to
solve yet. I have a measure in which I need to have two voices.  The bottom
voice is sixteenth notes and the top voice is eighth notes.  The time is
4/4 and the top voice only goes for the first three beats of the measure.
I tried the \context thing but I doubt that I'm using it correctly.  Can it
start at any time, or does it need to be invoked at the beginning of the
file?  I tried starting it up in the measure where I needed it.

In another measure I need to do this:
|  |  |  |

Can someone point me to the right place in the docs?  I have the doc

Another problem: I have a clef change during a beam.  There are four
sixteenth notes in this beam, the clef change occurs after the first note
of the beam.  I got the beam out of the way of the clef using;

\property Voice.Beam \set #'staff-position = #-10

It looks great but the beamed group immediately before it as well as all
following beams are adjusted.  How do I limit the change to this one beamed


Some comments:

The file I'm working on originated on Windows with Finale 2000.  I saved
the file as .MID and used midi2ly.  The results were odd.  I had some
phantom notes appearing where none were coded.  I puzzled over this for a
while and finally decided to strip out all the midi related stuff in the
file.  Once I cleaned that out the phantom notes disappeared.  It happened
whether I saved the midi file as type 0 or type 1.  I think the phantom
notes were supposed to be in a much later measure.

I also tried using the etf2ly on an .etf file saved by Finale 2000.
Lilypond seemed to choke on it.  No ouput.

Just for fun I tried having Lilypond generate PS directly.  The file
displayed just fine in gv (a bit "out of focus" in appearance) but when I
tried printing, the noteheads were printed as "$".  I suspect that I need
to move/link the .pfa files to a place where gs can find them (but why did
it display properly?).


David Bobroff

reply via email to

[Prev in Thread] Current Thread [Next in Thread]