[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond build trouble

From: Jan Nieuwenhuizen
Subject: Re: Lilypond build trouble
Date: Fri, 31 May 2002 17:02:21 +0200
User-agent: Gnus/5.090006 (Oort Gnus v0.06) Emacs/21.2 (i386-debian-linux-gnu)

Carl McTague <address@hidden> writes:

> I'm using tcsh, but I just tried with bash and the same thing happens:

No, I'm sorry, you don't understand.  It's about what shell /bin/sh
is.  ./configure won't be processed by [t]csh.

>   WARNING: Please consider installing optional programs:  pktrace makeinfo 
> 4.1 (installed: found)
>   ERROR: Please install required programs:  gcc 2.8 (installed: found) c++ 
> 2.95 (installed: found) bison 1.25 (installed: found) guile-config 1.3.4 
> (installed: found)

Maybe you didn't remove config.cache, but I suspect you didn't do:

    bash ./configure

as a temporary workaround, but rather tried something like


which will still use your /bin/sh.

> I'm pretty sure I have good old sh,

Of what flavour?  A fix for ash is in CVS.

> but I can't seem to find a
> --version type argument to check; I at least have the manpage!

And what does your package manager say that /bin/sh is?


Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter       |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]