[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond build trouble

From: Jan Nieuwenhuizen
Subject: Re: Lilypond build trouble
Date: Fri, 31 May 2002 17:13:23 +0200
User-agent: Gnus/5.090006 (Oort Gnus v0.06) Emacs/21.2 (i386-debian-linux-gnu)

David Boersma <address@hidden> writes:

> I also tried in vain to compile the 1.5.59 sources on a Red Hat (6.2 I
> think) linux machine in our institute; although the failure is for a
> slightly different reason. The output of the command...:
> -------------------------------------------------------------------------
> rurik:lilypond-1.5.59:1008$ ./configure --prefix=/stage/rurik/emin/davidb
> -------------------------------------------------------------------------
> ...ends with:
> -------------------------------------------------------------------------
> WARNING: Please consider installing optional programs:  pktrace
> ERROR: Please install required programs:  gcc 2.8 (installed:

Hmm, gcc 2.8?  I think you found a bug.

> egcs-2.91.66) c++ 2.95 (installed: egcs-2.91.66)
> See INSTALL.txt for more information on how to build LilyPond
> Remove config.cache before rerunning ./configure
> -------------------------------------------------------------------------
> The INSTALL.txt says that 'EGCS 1.1 may work but is no longer supported.'

Yes.  That's because egcs 1.1 is now something like 4 years old.  Time
to upgrade :-)

> the phrase 'may work but' should be replaced by 'will not work and'.

Yes, maybe.  If you know to hack your way around the configure
process, it will probably work, but we decided not to put too much
time in supporting old software on one hand, and on the other,
checking versions for egcs is a nightmare: they made an ugly mess of

> I am a bit surprised, though; all linux machines in our institute seem to
> have egcs-2.91.66, also the relatively recently installed ones (one year
> ago), so it seems a bit drastic to me to stop support for this compiler.
> Version 1.4.13 compiles without problems, though (except for the docs).

Yes, that's why INSTALL says that it will probably work.  If someone
with a good egcs can send a patch for the configure check, we may
accept it.  However, I don't want configure to generate a Makefile if
there's not a good compiler, that's why configure is more strict, now.


Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter       |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]