[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PS failure with 1.6.6

From: Werner LEMBERG
Subject: Re: PS failure with 1.6.6
Date: Tue, 12 Nov 2002 15:12:35 +0100 (CET)

> > In fact it is even stranger: xdvi (22.29) fails to find the file,
> > whereas oxdvik (22.40f) succeeds (but the PS specials don't look
> > good -- ledger-lines are too high by about 1/4 notehead, braces
> > too small)

The latter is a bug in xdvi I think.  Try to use the greatest
magnification (press `1 s') and you should see correct ledger lines.

> > Looks as though xdvi doesn't even look for
> > with kpathsea!!

> Yeah, I also tried making symlinks to dvips from ps and tex in
> /usr/local/share/lilypond. Still no go. I'll just wait for 1.6.7 and
> hope the problem goes away as my passive-aggressive contribution to
> LilyPond development.

In my teTeX installation, xdvi uses the TEXPSHEADERS variable to find
PS header files like  I have the following
default value in texmf.cnf:

  TEXPSHEADERS = .;$TEXMF/{dvips,pdftex,tex,fonts/type1}//

This means that any file installed somewhere in $TEXMF/tex/... is
checked.  AFAIK, is installed in
/usr/share/texmf/tex on Debian (which I don't use), so it should be


  KPATHSEA_DEBUG=-1 xdvi foo.dvi &> foo.kpathsea.log

and analyze the log file to find out where xdvi searches

Hmm, I've just checked the texmf.cnf file from the TeX Live 7 CD, and
I see that things have changed compared to my old teTeX setup.  `tex'
is no longer part of the default TEXPSHEADERS, only the
program-specific variables contain it.

I'm not sure how to solve this.  The easiest (and probably cleanest)
solution is to add the following line (or something similar) to

  TEXPSHEADERS.xdvi = .;$TEXMF/{tex,pdftex,dvips,fonts/{type1,pfb}}//

I have mixed feelings with the other solution, namely to copy into the dvips subdirectory tree.  Perhaps
someone else can decide this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]