[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

The dreaded font problem (again)

From: Geoff Horton
Subject: The dreaded font problem (again)
Date: Mon, 24 Mar 2003 18:13:52 -0800 (PST)

I'm running Lilypond 1.6.6, installed from rpm, on a Red Hat 8.0
system. (Two of them, actually, and they're both doing the same thing).
When I run  xdvi on the dvi output, it looks fine, but the .ps and .pdf
are bad.

I have:
* Uninstalled and reinstalled the package. (There seems to be a bug in
the uninstall script, BTW. I have to create a bogus directory and
fonts.dir file to get it to run.)
* Verified that the .pfa files are where they belong, and that they are
the 1.6.6 versions (or at least that rpm installed them in a directory
labelled 1.6.6).
* Made sure that my files say "p"

When I follow this sequence:

"Run the command:
  tex testfont
Fill in:
  Name of font to test = feta20
  * \table
  * \bye

Look at the file using xdvi:
  xdvi testfont
you should see a table with different musical symbols.

  dvips -Ppdf -G0 testfont

Look at the Postscript file using gv (ghostview)
  gv   (or ghostview
you should see the same result.

Try to convert the file to PDF:

Look at the PDF file:
  acroread testfont.pdf
Again the document should look the same."

It works (generating a ton of fonts in the meantime). But when I try to
run the actual file (I'm using the sample file), I still
get garbage.

Any thoughts?



Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]