[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Font problem when upgrade from 1.4.x to 1.6.8-2; (Cygwin)

From: Mats Bengtsson
Subject: Re: Font problem when upgrade from 1.4.x to 1.6.8-2; (Cygwin)
Date: Mon, 12 May 2003 14:31:46 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

To avoid any risk of confusion: Whenever I wrote tetex-bin in the
earlier messages, I actually meant tetex-base.


Mats Bengtsson wrote:
The problem turns out to be trivial to fix for the maintainer of
tetex-tiny. The file cmr8.pfb is missing in the package.
Since Lilypond also uses sizes 5, 6 and 7, I recomment to add also
cmr5.pfb, cmr6.pfb and cmr7.pfb.

For those of you who have installed lilypond with tetex-tiny and
don't want to install the full tetex-bin package, this means that
you can simply fix your current installation by downloading the files
given above from
Save them to the directory
and run the command "texhash" once from the cygwin command window


Mats Bengtsson wrote:

I just tried to reinstall the whole cygwin environment from scratch
to try to repeat this problem.

It turns out to be a problem not in the lilypond package itself but
in the tetex-tiny package. As a workaround, you could rerun the
setup.exe file and add the package tetex-bin to the installation.
Unfortunately, the package is very large so I hope you don't connect
to internet using a phone modem.

I have not investigated fully what is wrong in tetex-tiny, but it
is somehow related to the font cmr8. The following test illustrates
the problem clearly:
tex testfont
  font to test: cmr8
  Commands: \table \bye
dvips testfont

When run with tetex-tiny, you get the courier font in the table
whereas you get the correct computer modern font with tetex-bin.


Joel McNary wrote:

For approximately a year I was happily using Lilypond version 1.4.? (not sure exactly which one...) However, my computer then crashed and I had to reinstall everything. I installed the latest binary distribution (1.6.8-2) for Cygwin, and now my lyrics print using a typewriter-font instead of the "pretty" font. I've tried all sorts of things but cannot seem to get it to display/print in the old font again. I've searched for anything relating to this problem, but cannot seem to find anything on-line. Does anybody have any ideas what I need to do?

Thanks for your help,

Joel McNary

Lilypond-user mailing list

        Mats Bengtsson
        Signal Processing
        Signals, Sensors and Systems
        Royal Institute of Technology
        SE-100 44  STOCKHOLM
        Phone: (+46) 8 790 8463                         
        Fax:   (+46) 8 790 7260
        Email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]