[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs and lilypond on OS X

From: Arvid Grøtting
Subject: Re: emacs and lilypond on OS X
Date: Thu, 03 Jun 2004 10:33:26 +0200
User-agent: Gnus/5.1001 (Gnus v5.10.1) Emacs/21.2 (berkeley-unix)

Jason <address@hidden> writes:

> I was hoping to maybe get a little help:  I can't seem to get emacs to
> do all they indenting, highlighting, etc. with lilypond.  I'm on OS X,
> panther, and I have installed lily 2.2.2 with fink.  I have tried
> installing a new version of emacs using fink, I've even tried using
> vim, and it will not do it either (according to the manual, vim
> "should" do these things on its own once lily is installed.  I've
> tried putting the several .el files in various site-lisp
> directories...

I *think* the approperiate .el and .elc files are installed
automatically, but you need some magic to invoke them from your emacs.

Here's relevant portions of the .emacs from my Powerbook; paste this
snippet into your .emacs file (or create it, in your home directory,
if you don't already have it):


  ;; custom-set-variables was added by Custom -- don't edit or cut/paste it!
  ;; Your init file should contain only one such instance.
 '(global-font-lock-mode t nil (font-lock)))

(load "lilypond-init")


(If you've already used Custom, you'll want to set Global font lock
from there or from the Options menu, and just insert the last line.)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]