[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: insertion of UTF-8 characters

From: Jonathan Kulp
Subject: Re: insertion of UTF-8 characters
Date: Mon, 13 Oct 2008 20:23:55 -0500
User-agent: Thunderbird (X11/20080925)

Try copying this character in there:


I tried the way the docs say, as well, and never got it to work. I found that if I just copied an actual copyright symbol into my files and made sure the editor was saving in utf-8 encoding, it all worked fine.


Tom Cloyd wrote:
forgot this: I'm running Ly 2.11.60, on Kubuntu Linux 8.04.1

Tom Cloyd wrote:
The documentation [/Lilypond notation reference.pdf/, “3.3.3 Text encoding”, pdf p. 318.] states that UTF-8 coding is used in Ly and that UTF-8 hex codes can be inserted into text. An example is given, and I show it here using the code of interest to me - that for the Copyright sign:

#(ly:export (ly:wide-char->utf-8 #xc2a9))|

|This example has no context, and when I put it in one I cannot get it to work. I suggest that the documentation be modified to give one. Meanwhile, I need a solution to the problem of how to insert a Copyright sign into the copyright line. Here's what I tried:

\header {...
copyright = "#(ly:export (ly:wide-char->utf-8 #xc2a9)) 2008"

It produced this in the PDF output:

#(ly:export (ly:wide-char->utf-8 #xc2a9)) 2008

Placing the UTF code export line outside of the quotes wouldn't even compile.

Can anyone suggest how to do this?




Jonathan Kulp

reply via email to

[Prev in Thread] Current Thread [Next in Thread]