[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: midi2ly

From: Jonathan Kulp
Subject: Re: midi2ly
Date: Sat, 18 Oct 2008 20:58:42 -0500
User-agent: Thunderbird (X11/20080925)

Hi Martin,

I ran the same commands as you with the same results. I can't comment on the maintenance of the program or the non-functioning -o flag, but I can say that the time signature problem is because "\time 3/4" is in a variable that wasn't included in the \score block. If you either put \time 3/4 into the variable called "trackBchannelA" just before the notes begin, or add "\trackA" to the \score block right after where it currently says "\trackB", then the melody appears properly in 3/4. Apparently the midi2ly conversion does not recognize pickup notes either (not really surprising) so you also have to specify "\partial 4" (i.e. quarter-note pickup) before the first notes begin so that the downbeat is in the right place. The barchecks are also misplaced by default so you get warnings about this when running the file:

trackBchannelA = \relative c {
\time 3/4
\partial 4  g''8. g16
  a4 g c |
  % 2
  b2 g8. g16 a4 |
  % 3
  g d' c2 |
  % 4


With a midi2ly conversion you can expect to have to do some manual corrections. I remember trying midi2ly myself several months ago on some longer, polyphonic files, and they were such a disaster that it would be easier to start over and enter all of the notes from scratch. The musicXML2ly conversion works *much* better, with only minor cleanup necessary even for pretty complex files.



Martin Tarenskeen wrote:
Hi Lilyponders,

I'm new in this newsgroup, forgive me if my question had already been discussed.

I'm trying the midi2ly utility. I have attached (I hope this mailinglist accepts attachments)
1. driekwart.mid - a few bars in 3/4 time (happy birthday,)

I tried this:
# midi2ly -o -d 16 driekwart.mid

The result was a file named "" and not "". The -o option is ignored. A bug, or am I doing something wrong ?

Another problem: If I do # lilypond the resulting ps/pdf files show happy birthday in 4/4 time, but I do see 3/4 time in Again a bug, or newbie-ignorance ?

Last question: shows \version "2.7.18" while I'm testing lilypond 2.11.62. Has the program not been maintained/updated for a long time ? Shouldn't someone do that, or is everyone focused on musicxml2ly these days. I know: MIDI sucks when it comes to producing sheet music. But that's no excuse for a malfunctioning midi2ly utility.

The produced by midi2ly looks like this:

% Lily was here -- automatically converted by /usr/bin/midi2ly from 
\version "2.7.18"

trackAchannelA =  {
  \key c \major
\tempo 4 = 120 \time 3/4 }

trackA = <<
  \context Voice = channelA \trackAchannelA

trackBchannelA = \relative c {
  g'' a g c |
  % 2
  b2 g4 a |
  % 3
  g d' c2 |
  % 4

trackB = <<
  \context Voice = channelA \trackBchannelA

\score {
    \context Staff=trackB \trackB


lilypond-user mailing list

Jonathan Kulp

reply via email to

[Prev in Thread] Current Thread [Next in Thread]