[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

memory problem?

From: David Bobroff
Subject: memory problem?
Date: Wed, 29 Apr 2009 11:34:13 +0000
User-agent: Thunderbird (Windows/20090302)

I'm having a problem that I don't understand. I have a file which makes a book of etudes. I'm using a series of \bookpart{} blocks inside a \book{} block. When I try to run the whole thing I get this at the end of the terminal output:

Layout output to `'...
Converting to `./ten.pdf'.../usr/local/lilypond/usr/share/lilypond/current/scm/backend-library.scm:24:15: In procedure system in expression (system silenced): /usr/local/lilypond/usr/share/lilypond/current/scm/backend-library.scm:24:15: Cannot allocate memory
bash-3.2# emacs&
[8] 7951

I tried to learn if the problem was a particular section of either the file I'm using to generate the book or with the definitions file which is separate. I tried commenting out the second half and then the first half. Both halves worked independently without trouble. When I try to run the whole thing I get the above. The definitions file is 5,000+ lines.

I'm running LilyPond mostly inside coLinux on an XP machine. I thought maybe that could have something to do with this. I tried running the same files natively in Windows. Same result, except that the Windows command prompt was not so generous with the mode of failure. All I got was:

Layout output to `'...
Converting to `./ten.pdf'...
error: failed files: "ten"



reply via email to

[Prev in Thread] Current Thread [Next in Thread]