[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lilypond-book on osx 10.4

From: James E. Bailey
Subject: Re: lilypond-book on osx 10.4
Date: Wed, 28 Oct 2009 19:34:31 +0100

On 28.10.2009, at 08:13, James E. Bailey wrote:

On 28.10.2009, at 03:23, Patrick McCarty wrote:

On Tue, Oct 27, 2009 at 11:14 AM, James E. Bailey

Ah, I just realised you meant with the development version (it's not the
main version I use, so I didn't think about it). I still have the md5
19:13:40 jamesebailey lilypond snippets:which python
19:14:24 jamesebailey lilypond
lilypond-book (GNU LilyPond) 2.13.6
Reading lily-book-sample.lytex...
Running latex...This is pdfTeXk, Version 3.1415926-1.40.9 (Web2C 7.5.7)
 %&-line parsing enabled.
entering extended mode
LaTeX2e <2005/12/01>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang,
yphenation, basque, danish, dutch, finnish, french, german, ngerman,
 italian, bokmal, nynorsk, polish, portuguese, spanish, swedish, ukenglish,
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
No file tmp3fOBCU.aux.
(./tmp3fOBCU.aux) )
No pages of output.
Transcript written on tmp3fOBCU.log.
DeprecationWarning: the md5 module is deprecated; use hashlib instead
  from md5 import md5
Traceback (most recent call last):
line 2136, in <module>
    main ()
line 2118, in main
    chunks = do_file (files[0])
line 2022, in do_file
    do_process_cmd (chunks, input_fullname, global_options)
line 1851, in do_process_cmd
    outdated = [c for c in snippets if c.is_outdated
(options.lily_output_dir, output_files)]
line 1379, in is_outdated
    found, missing = self.all_output_files (output_dir, current_files)
line 1314, in all_output_files
    base = self.basename()
line 1270, in basename
    cs = self.get_checksum ()
line 1258, in get_checksum
    from md5 import md5
  File "/Users/jamesebailey/lib/python2.6/", line 10, in <module>
    from hashlib import md5
  File "/Users/jamesebailey/lib/python2.6/", line 136, in <module>
    md5 = __get_builtin_constructor('md5')
  File "/Users/jamesebailey/lib/python2.6/", line 63, in
    import _md5
ImportError: No module named _md5

I wish I could help more with this, but I can't reproduce your
problem.  IWBN if I had access to Mac OSX 10.4 machine, but I don't.

I thought at first that Python 2.6 was bundled in the darwin
installers now, but I'm not so sure.  Is the python executable in your just a wrapper or something?
Because I see that the md5 library in your backtrace is part of a
separate Python installation.


I've kind of solved the problem by installing python version 2.4.6. I figured since I was getting module deprecated warnings, I'd go back to the earliest usable version and see what happens. I get a .tex file output at least.

James E. Bailey

Okay, yeah, that solved the problem. downgrading to python 2.4.6 solved the problem and lilypond-book works perfectly now. Whom do I talk to to have this updated in the distributed binary? Or is this not a feasible option because 10.5 and 10.6 don't have this problem?

James E. Bailey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]