[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond-mode in emacs on WinXP

From: Ralph Palmer
Subject: Re: Lilypond-mode in emacs on WinXP
Date: Thu, 10 Jun 2010 13:44:08 -0400

Thanks, David - worked beautifully! Saved me a lot of time and aggravation. I had tried searching the docs, but found only Linux instructions. I also tried searching  the list archives and found only a thread I could not understand.


On Wed, Jun 9, 2010 at 5:14 PM, David Stocker <address@hidden> wrote:
Hi Ralph,

Browse to the folder "C:\Documents and Settings\User\Application Data\.emacs.d" or, if ".emacs.d" isn't already present, then create a new directory with that name in "Application Data" Make sure you change "User" in the path to whatever your actual user account's name is.

In the ".emacs.d" directory, open (or create) a file called "init.el"

In that file, paste the following lines:

(setq load-path (append (list (expand-file-name "C:/Program Files/LilyPond/usr/share/emacs/site-lisp")) load-path))

(autoload 'LilyPond-mode "lilypond-mode" "LilyPond Editing Mode" t)
(add-to-list 'auto-mode-alist '("\\.ly$" . LilyPond-mode))
(add-to-list 'auto-mode-alist '("\\.ily$" . LilyPond-mode))
(add-hook 'LilyPond-mode-hook (lambda () (turn-on-font-lock)))

Make sure that in the section starting "(expand-file-name "C:/..." points to the "site-lisp" folder in you LilyPond installation. Save the file and try opening a *.ly file in Emacs.

BTW, I'm not a programmer and I have no experience with lisp. I adapted this from some instructions I found online (possibly the "Usage" section of the LilyPond docs) and extrapolated from what I knew about the .emacs.d file in my UbuntuStudio installation, which came with LilyPond pre-installed and had Emacs working with lilypond-mode out of the box.

I hope this works for you.


On 06/09/2010 03:49 PM, Ralph Palmer wrote:
Greetings -

I've been forced (temporarily,  I hope) onto a WinXP Pro laptop. I've successfully downloaded LilyPond and Emacs 22.3. I cannot figure out how to get Emacs to recognize (much less accept as default for .ly files) lilypond-mode. If anyone out there has successfully gotten Emacs to work with lilypond-mode on WinXP and can explain the process to me, I would be grateful.

I appreciate your time and attention,


Ralph Palmer
Montague City, MA
_______________________________________________ lilypond-user mailing list address@hidden

David Stocker

lilypond-user mailing list

Ralph Palmer
Montague City, MA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]