[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ghostscript-8.70-6 broke my lilypond, no more PDF

From: Matthias Kilian
Subject: Re: ghostscript-8.70-6 broke my lilypond, no more PDF
Date: Mon, 25 Apr 2011 23:16:51 +0200
User-agent: Mutt/


On Mon, Apr 25, 2011 at 03:59:17PM -0500, address@hidden wrote:
> I ran the CentOS recommended updates and I updated from
> ghostscript-8.15.2-9.12 to ghostscript-8.70-6.
> Since that time, lilypond no longer works for me in that
> lilypond .ps files but no longer produces .pdf files.
> Here is what the output at the command line look like:
>    GNU LilyPond 2.12.3
>    Processing `'
>    Parsing...
>    Interpreting music... [8][16][24][32]
>    Preprocessing graphical objects...
>    Finding the ideal number of pages...
>    Fitting music on 1 page...
>    Drawing systems...
>    Layout output to `'...
>    Converting to `./song02.pdf'...
>    -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite
>    -sOutputFile="./song02.pdf" -c .setpdfwrite -f ""' failed (256)
>    error: failed files: ""
> Have I stumbled onto a bug?  How can I get lilypond to
> produce PDF files again.

That run should have left over the file `'. Could you try
to run ghostscript manually to convert it to pdf (but omit the `-q'
flag)? Like, just run

        -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 \
        -sDEVICE=pdfwrite -sOutputFile="./song02.pdf" -c .setpdfwrite \
        -f ""

from your shell. This may give a hint about what's wrong.

FWIW, on OpenBSD, where I'm the maintainer of both lilypond and
ghostscript (no coincidence, btw), lilypond-2.12.3 works well with
ghostscript-8.63, and it also worked with ghostscript-8.69, -8.70
and -9.00 (which I all tested during the long way to update


reply via email to

[Prev in Thread] Current Thread [Next in Thread]