[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to find file "ice-9/boot-9.scm" in load path

From: Helge Kruse
Subject: Re: Unable to find file "ice-9/boot-9.scm" in load path
Date: Fri, 03 Feb 2012 08:20:39 +0100
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20111222 Thunderbird/9.0.1

Am 02.02.2012 19:18, schrieb Ralph Palmer:
On Tue, Jan 31, 2012 at 2:03 AM, Helge Kruse<address@hidden>wrote:

I think this is better in the bug mailing list. Thererfore I sent it here

I try to follow the instructions on this page:**Documentation/extending/**

Unfortunately I get an error message, when I try to start guile.exe:
  ERROR: In procedure primitive-load-path:
  ERROR: Unable to find file "ice-9/boot-9.scm" in load path

The PATH contains the path to Lilypond: "C:\Program Files
(x86)\LilyPond\usr\bin". So I am sure that I use this copy of Lilypond.

The documentation mentions that I have to add an environment variable
C:\>  set GUILE_LOAD_PATH="../usr/shr/**guile/1.8"
-- same error
The same appears with each of these settings:
GUILE_LOAD_PATH="C:/Program Files (x86)/LilyPond/usr/shr/guile/**1.8"
GUILE_LOAD_PATH="C:/Program Files (x86)/LilyPond/usr/share/**guile/1.8"
GUILE_LOAD_PATH="C:\Program Files (x86)\LilyPond\usr\share\**guile\1.8"

Let's check if the directory in GUILE_LOAD_PATH is valid:
C:\>  dir /b %GUILE_LOAD_PATH%\ice-9\bo*

Now I am convinced that the GUILE_LOAD_PATH is correct. But I failed to
start the GUILE prompt. Is there something that I have missed? Is there a
way to learn Scheme with my Lilypond 2.14.2?

I am running Lilypond on Windows-7 (64bit) German.


Greetings, Helge -

I am running LilyPond 1.14.2 under Windows XP SP3. I can run LY, and cannot
duplicate your error. I've copied it back to the user list, since I cannot
confirm the problem as a bug. Can anyone out there help Helge?

Take care,


Hello Ralph,

thanks for trying to reproducing the bug.

Well, it's still a bug. When I run guile.exe as administrator it succeeds. But running guile.exe as a user without administrative rights it fails to load boot-9.scm.

You can see here what happens when the GUILE_LOAD_PATH is set to "SHARE\GUILE\1.8" This is intentionally in capital letters. The windows O/S doesn't care but you can see, when this variable has been used.

CreateFile C:\Program Files (x86)\LilyPond\usr\share\guile\1.8 --> SUCCESS
There are some additional file open operations but you can see, that the variable GUILE_LOAD_PATH has *not* been used to resolve the valid load path.

Non-adminstrative user (Helge):
CreateFile C:\Users\Helge\SHARE\GUILE\1.8\ --> PATH NOT FOUND
CreateFile C:\usr\share\guile\site\ --> PATH NOT FOUND
CreateFile C:\usr\share\guile\1.8\ --> PATH NOT FOUND
CreateFile C:\usr\share\guile\ --> PATH NOT FOUND
CreateFile C:\Users\Helge\share\guile\1.8\ --> PATH NOT FOUND
CreateFile C:\Users\Helge\SHARE\GUILE\1.8\ice-9\ --> PATH NOT FOUND

So the bug is: GUILE_LOAD_PATH is appended to the home directory of the non-adminstrative user instead of either append it to the directory where guile.exe is started or using it as an absolute path.

Workaround: When you set GUILE_LOAD_PATH to the following value, you can run guile.exe as non-administrative user:
(must not be surrounded by "")


reply via email to

[Prev in Thread] Current Thread [Next in Thread]