[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Any advice for getting emacs working with lilypond on MacOsX?

From: rif
Subject: Any advice for getting emacs working with lilypond on MacOsX?
Date: Fri, 9 May 2014 10:43:07 -0700

The documentation seems spotty and inadequate compared to when I tried this a few years ago.  I feel hopelessly lost.

I found This tells me I need to do a "make install".  This implies I need the source to do anything at all with emacs mode? I found a source bundle here, along with the warning "We do not recommend that you attempt to build LilyPond yourself; almost all user needs are better met with the pre-built version." Unclear whether using emacs is included in "almost all user needs" or not.

[Side issue: the parallel structure of the documentation on the website is *very* confusing.  In particular, I spent quite a few minutes puzzled about why the "Source" link in the Download tab at the top of led to rather than back to the source bundle.  Is this intentional?]

OK, so I download the source bundle, and now I'm left with no more instructions than "make install".  But in what directory?  I tried it in the elisp directory and the lilypond directory above it, but in both cases I got errors.

I also tried skipping the install step and just directly pointing at the directories.  This seems to give me at least a partial solution, although it's warning me that lilypond-words doesn't exist.  Probably because it needs to compile that somehow?

Am I missing something basic/obvious/simple?  Any advice is welcome.  I'd love to get emacs and lilypond working.  I'm happy to contribute a doc fix to make this easier for others later.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]