[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Frescobaldi] Re: Mac testers needed for Frescobaldi!

From: Davide Liessi
Subject: Re: [Frescobaldi] Re: Mac testers needed for Frescobaldi!
Date: Mon, 12 May 2014 00:44:14 +0200

2014-05-10 16:49 GMT+02:00  <address@hidden>:
> I had been using Frescobaldi successfully on OS X 10.9.2, installed via
> Homebrew. Everything was working well. A few days ago, the Music View (PDF
> viewer) stopped working, showing "Unable to load popplerqt4 module". I don't
> know what broke this. I recently installed a Canon Printer Driver system
> update from Apple, but other than that, I haven't done anything to my
> system.
> I tried uninstalling and reinstalling via Homebrew without success. Well,
> the install completed successfully, but still no Music View.

Did you uninstall and reinstall only Frescobaldi?
You should try to uninstall Frescobaldi, Poppler and Qt and then
reinstall Frescobaldi: this solved the problem for a user (see the
messages of April 3 in this thread in the mailing list of Frescobaldi:!topic/frescobaldi/hXK3qS-_jsw).
Anyway, I'm not a Homebrew expert: you should ask Marnen about this
problem (I'll put him in cc: in this message).

> Next, I downloaded the DMG containing the standalone Mac app to see if that
> would work better for me. Sure enough, the Music View reappeared in all its
> glory. But I noticed that the MIDI player would no longer work for me. My
> setup is identical to when I was using the Homebrew version, and I had
> playback working with both SimpleSynth and Qsynth. With the standalone Mac
> app, though, when I click "Refresh MIDI ports" in MIDI settings with Qsynth
> running, nothing shows up in the "Player output" dropdown menu like it used
> to for me. At the top, it says "There are no MIDI output ports available on
> your system. Make sure PortMIDI is installed..."
> Well, PortMIDI was installed via Homebrew, but I don't think the standalone
> app is seeing it. I looked in the Frameworks folder inside the Frescobaldi
> app bundle, but I did not see anything for PortMIDI there. Was this a
> packaging oversight or something else?

A packaging oversight, indeed; thanks for reporting.
The behaviour is slightly different on my machine (PortMIDI installed
via MacPorts is recognized by the application bundle), but I confirm
that I didn't include PortMIDI in the bundle.
I'll take care of this as soon as possible.

Best wishes.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]