[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: convert-ly question

From: Tim McNamara
Subject: Re: convert-ly question
Date: Sat, 17 May 2014 11:53:24 -0500

On May 17, 2014, at 11:41 AM, Malte Meyn <address@hidden> wrote:

> On 17.05.2014 18:20, Tim McNamara wrote:
>> On May 16, 2014, at 1:54 PM, David Kastrup <address@hidden> wrote:
>>> Tim McNamara <address@hidden> writes:
>>>> Is there a syntax for running convert-ly on a directory without having
>>>> to cd into the directory and invoking
>>>>       convert-ly -e *.ly
>>>> There doesn’t seem to be a recursive option.  Since I’ve got .ly files
>>>> in 158 different directories it’d be really nice to be able to batch
>>>> update them with something like:
>>>>     convert-ly -e -r *.ly
>>>> instead of having to cd in to 158 directories by hand.  Maybe there is
>>>> good reason for convert-ly not having this capability.
>>> find -name "*.ly" -exec convert-ly -e {} \;
>>> is how one would likely do it under POSIXy systems.
>> Thanks, although when I run this I get:
>> find: illegal option -- n
>> usage: find [-H | -L | -P] [-EXdsx] [-f path] path ... [expression]
>>            find [-H | -L | -P] [-EXdsx] -f path [path ...] [expression]
>> This is on a Mac using bash as the shell.
> Have you already tried the simpler version I posted yesterday? I wrote 
> something like “for Linux” but if you have a bash on a Mac (I didn’t know 
> there was something like that ;)) it should work for you, too.

That one worked where David’s didn’t.  I don’t understand shell scripting 
adequately to understand the difference.  

reply via email to

[Prev in Thread] Current Thread [Next in Thread]