[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: musicxml2ly 2.20 bug

From: David Kastrup
Subject: Re: musicxml2ly 2.20 bug
Date: Sun, 22 Mar 2020 16:08:15 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

David Wright <address@hidden> writes:

> On Sun 22 Mar 2020 at 10:54:29 (+0300), Павел Буданов wrote:
>> I tried to use musicxml2ly from official repository of manjaro linux and
>> get this output:
>> Traceback (most recent call last):
>>   File "/usr/bin/musicxml2ly", line 44, in <module>
>>     import lilylib as ly
>> ImportError: No module named lilylib
>> Then I tried to install lilypond from official cite via shell script. It
>> gives following output:
>>   File "./lilypond/usr/bin/musicxml2ly", line 2264
>>     if current_staff and staff <> current_staff and not
>> n.get_maybe_exist_named_child('chord'):
>>                                 ^
>> SyntaxError: invalid syntax
> If you run musicxml2ly from the official repository of manjaro linux,
> it should use the lilypond from the official repository of manjaro
> linux as well.
> If your only lilypond is the one downloaded from the "official [s]ite",
> by which I assume you mean, then you should run the
> musicxml2ly that's included in the download.
> Both methods include the code to ensure that they use the correct
> version of Python, python2. It looks as if you've circumvented that
> code somehow, and are running python3 instead. I've never run a
> system where "python" means python3, but manjaro/archlinux is one
> of these, so the wrapper is specially important. (Fedora is another.)

For what it's worth, Ubuntu "Focal" seems to have no "python" and you
need to be explicit about whether you want "python2" or "python3".

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]