[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond 2.20 on Mac 10.15

From: Moritz Heffter
Subject: Re: Lilypond 2.20 on Mac 10.15
Date: Thu, 26 Mar 2020 12:57:57 +0100

Well this is bringing me one step further. I think the problem is that some 
libraries are not found. Especially guile.

I’ve now completely removed macports (I’ve installed it only because of 
Lilypond) and reinstalled the Lilypond package of version 2.19 from Hans again. 
It installs into /opt/lilypond by default and I can’t prevent this. The result 
is again a segmentation fault. BTW the problem is the same with the 2.19 oder 
2.20 version from macports.

BTW, /opt is in read-only mode. I’m not able to remove it. Maybe I have to 
switch off the system integrity protection for that but I’m doing this only if 
I have time.

@Ralf: Same result with the App-Package of version 2.20 from Marnen. The 
lilypond binary which is in 
/Applications/ is canceled with a 
segmentation error.

The binary in /Applications/ starts the 
app, but the app doesn’t typeset anything. Maybe due to the problem above.


> Am 26.03.2020 um 11:09 schrieb Hans Åberg <address@hidden>:
>> On 26 Mar 2020, at 10:57, Moritz Heffter <address@hidden> wrote:
>> The error is logged for lilypond-bin when I run lilypond from the Terminal:
>> Process:               lilypond-bin [8616]
>> Path:                  /opt/lilypond/*/lilypond-bin
>> Identifier:            lilypond-bin
>> Version:               0
>> Code Type:             X86-64 (Native)
>> Parent Process:        zsh [1205]
>> Responsible:           Terminal [1141]
>> The zsh reports me the segmentation fault error.
> The program from the MacPorts installer is
>  /opt/lilypond/bin/lilypond
> In the standard install of MacPorts, it is
>  /opt/local/bin/lilypond
> The only difference is the install location, /opt/lilypond/ vs /opt/local/.
> There is:
> % /opt/local/libexec/lilypond-bin
> GNU LilyPond 2.19.84
> /opt/local/share/guile/1.8/srfi/srfi-1.scm:223:1: In procedure dynamic-link 
> in expression (load-extension "libguile-srfi-srfi-1-v-3" "scm_init_srfi_1"):
> /opt/local/share/guile/1.8/srfi/srfi-1.scm:223:1: file: 
> "libguile-srfi-srfi-1-v-3", message: "file not found"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]