[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

How to compile Lilypond files using Emacs?

From: Parviz Farnia
Subject: How to compile Lilypond files using Emacs?
Date: Sun, 26 Jul 2020 16:54:31 +0200


I would like to ask a question about using Lilypond with Emacs. According to the online documentation it is possible to use Lilypond with Emacs:

The problem is that I cannot get it to work and I would appreciate if you could kindly give me a hand.

My working environment:
In Lilypond installation directory I found the following files:

What I did, was to copy all of these files in the following directory


This the directory in my .emacs.d configuration directory where I put all .el scripts that are to be read and loaded by Emacs.

Once a Lilypond file (.ly) has been opened in Emacs, I run the following commands respectively in order to enable Lilypond in Emacs:
This gives me the syntax coloring, but that's all, and when I try to compile the file by doing "C-c C-b" (Lilypond-command-buffer) I get the following error message:

-*- mode: compilation; default-directory: "c:/Users/MyUserName/AppData/Local/Temp/" -*-
Compilation started at Sun Jul 26 16:07:03

cd  c:/Users/MyUserName/AppData/Local/Temp/; lilypond "c:/Users/MyUserName/AppData/Local/Temp/emacs-lily".ly
The filename, directory name, or volume label syntax is incorrect.

Compilation exited abnormally with code 1 at Sun Jul 26 16:07:03

However if I open a Windows command line (cmd.exe) and I copy/paste from the above, the following line from Emacs compilation buffer:

lilypond "c:/Users/MyUserName/AppData/Local/Temp/emacs-lily".ly

When I run this command it works like a charm without any problem, it compiles and produces the corresponding output PDF file. So I don't really understand what's happening in Emacs while compiling Lilypond files.

Besides, I don't get any autocompletion at all for Lilypond in Emacs.

So if anyone has succeeded in running Lilypond with Emacs in a Windows environment, I'd be so grateful if you could kindly make some clarification and indicate what's wrong with my configuration.

Thanks in advance.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]