[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: error :GUILE signaled an error for the expression

From: David Olson
Subject: Re: error :GUILE signaled an error for the expression
Date: Tue, 13 Jul 2021 14:34:29 -0400 (EDT)

just wondering...

has anyone written a song about this subject?

The Sinoglyphic implementation blues

I've got those mean old Sinoglyphic implementation blues
Got'em in the keyboard,
ev'ry stroke so misconstrued.

When the inkstone's dry, I gotta cry,
Gotta bury my brush, hear my ancestors sigh,

the Consortium may claim,
but the bugs remain.

And there ain't no digital attributes
To solve my Sinoglyphic blues.

(poetry unworthy of this talented group, to be sure)
(but then, the text of ANY song operates at a level at least 30 IQ points below the median of the singers)
(why is that?)
(below the dignity of the neocortex, but lodged in the periaqueductal grey?)

Not a fan of  かな漢字変換 feature on Mac OSX (System 8 and System 9 were much better).

David Olson

From: "ming tsang" <>
To: "lilypond-user" <>
Cc: "c sorensen" <>
Sent: Tuesday, July 13, 2021 10:36:27 AM
Subject: Re: error :GUILE signaled an error for the _expression_

Carl :  Thank you for the info.  How can I  change your display/markup font to be a font that includes CJK characters?
David Wright :
Thank you for reminding me about my problem way back in 2015. You suggested using the eps image in the file name.  I did not know how to create an eps image for the file name.  So I end up not using utf-8 in the file name.  It served me fine these years.
Now I created a folder name with utf-8 characters without realizing it will affect the folder name as with  file name.
If this is the way lilypond works, I will remember not to use utf-8 characters in the folder and the file name.

One  strange thing is that this only affects the 
"\markup  \wordwrap-string #(command-line)" --the example four.

I have different ways to display folder/
%%lily code
%    updated LSR 197 --
\version "2.23.3"

#(define comml    (command-line))
#(define filen    input-file-name)
#(define siz      (object->string (stat:size (stat filen))))
#(define ver      (lilypond-version))
#(define dat      (strftime "%m/%d/%Y" (localtime (current-time))))
#(define tim      (strftime "%H:%M:%S" (localtime (current-time))))
#(define modt     (stat:mtime (stat filen)))
#(define modts    (strftime "%m/%d/%Y %H:%M:%S" (localtime modt)))
\markup { "..... example one ....." }
\markup \column {
  \line { "File Name = "        \filen }
  \line { "File Size = "        \siz   }
  \line { "LilyPond Version = " \ver   }
  \line { "Date Processed = "   \dat   }
  \line { "Time Processed = "   \tim   }
  \line { "Last Modified = "    \modts }
  \line  { "Command Line = "     \comml }

\version "2.23.3" % or newer

filename = #(define-scheme-function () ()
              (car (ly:input-file-line-char-column (*location*))))
\markup { "..... example two ....." }
\markup { "File Name =" \filename }
\header { dedication = \markup { \filename } }

\version "2.23.3"

#(define commandLine (object->string (command-line)))
\markup { "..... example three ....." }  
\markup { \wordwrap-string { \commandLine } }

\version "2.23.3"
\markup { "..... example four ....." }
\markup \wordwrap #(command-line)
%end of example code.

The above test is for folder names containing utf-8 characters.
Later today I will test the folder and filename containing utf-8 characters to see the effects.

Thank you for your help.
yMing Tsang

On Tue, Jul 13, 2021 at 12:15 PM David Wright <> wrote:
> Date: Tue, 13 Jul 2021 08:14:51 -0700
> From: Knute Snortum <>
> To: ming tsang <>
> I don't think the error is caused by you not having the font, I think it's
> that the font doesn't have a glyph (character, sort of) for U+FFFD. I don't
> think all of the UTF-8 characters will work in the music view. The problem
> is the non-latin characters in the path of the source file you're trying to
> compile.

I seem to remember writing:
which refers back to:
to which my reply would be the same:
except for the reference, updated here to:

NR § 1.8.2 Formatting text   →   § Graphic notation inside markup


> On Tue, Jul 13, 2021 at 6:41 AM ming tsang wrote:
> > Hi lilponder:
> >
> > There is a utf-8 in the file path. When I ran the file I got the following
> > warning message ---- warning: no glyph for character U+FFFD in font
> > `C:/LilyPond_2-23-3/usr/share/lilypond/current/fonts/otf/C059-Roman.otf'
> >
> > [image: image.png]
> > How can I obtain the otf/C059-Roman.otf font.
> >
> > Shalom,
> > yMing


On Wed, 30 Jan 2019 16:42:22 +0000 (UTC) MING TSANG wrote:

I copy the above snippet and name it and run with fracobaldi3.01 + lilypond2.19.82 it produces desired file infomation.

Then I rename the file as test_中文.ly (UTF-8 Chinese characters) and execute and the following error occurs:

Starting lilypond-windows.exe 2.19.82 [test_中文.ly]...
warning: cannot find file: `C:/Users/yming/Documents/test_??.ly'
fatal error: failed files: "C:/Users/yming/Documents/test_??.ly"
Exited with return code 1.

Question: Window 10 support UTF-8 file name and lilypond does not. Is there any work around?


On Thu, 12 Nov 2015 at 14:53:31 +0000 (UTC) MING TSANG wrote:

Hi, lilyponders:

I ran the attach file and got the following.
Question: can this be solved? How? Appreciate help given.

Starting lilypond.exe 2.19.31 [test_ymt-曾煒明.ly]...
Processing `K:/LILY_POND/test_ymt-������.ly'
Interpreting music...
Preprocessing graphical objects...
Finding the ideal number of pages...
(lilypond.exe:1892): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()
warning: no glyph for character U+FFFD in font `C:/Windows/fonts/times.ttf'


ming (lyndon) tsang

reply via email to

[Prev in Thread] Current Thread [Next in Thread]