[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] Re : Compile and run linphone-android

From: Marotte Gaetan
Subject: [Linphone-developers] Re : Compile and run linphone-android
Date: Thu, 27 Dec 2012 13:35:13 +0100

Hi, are you sure that you use recursive flag with git clone? Sometimes i had to delete the entire folder and clone it again to have it. I had it complete, compiled but at crashing at runtime message unable to load library, maybe bcause of prepare sh that doesn't work due to ndk path missing ?

Envoyé depuis mon smartphone Xperia™ smartphone

-------- Message original --------
Objet : [Linphone-developers] Compile and run linphone-android
De : Taruna Sharma <address@hidden>
À : "address@hidden" <address@hidden>
Cc :

Hi All,

I have downloaded linphone-android source code from github and now trying to compile it. The read me file says that i have to run $ make in the top directory of the project in order to download ilbc code files, but it doesnt work.It says operand missing. So I ran ./ /path-to-ndk ,it successfully ran,after that i ran /oath-to-ndk/ndk-build, this also ran successfully. After this,I tried to import the linphone-android project into eclipse,it asks me to import other projects to like mediastreamer,videoactivity,android test,etc. I imported all.But then, the source code of linphone-android shows errors like, org.linphone.core.Log is not resolved. I then looked into the downloaded code,there is no package like org.linphone.core. Have I missed anything?

Best Regards,

Taruna Sharma
Software Engineer



reply via email to

[Prev in Thread] Current Thread [Next in Thread]