[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] ZRTP cache broken in 3.8.x?

From: Johan Pascal
Subject: Re: [Linphone-developers] ZRTP cache broken in 3.8.x?
Date: Tue, 25 Aug 2015 04:36:48 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.8.0

Hi Liviu,
I was able to reproduce the bug using the build from the PPA, but when I tried to build everything from sources using the released versions it works.

I had a quick look at the build logs on the PPA, and for bzrtp 1.02 on trusty I found this in the build log(

checking for LIBXML2... no
configure: WARNING: libxml2 not found. Disabling cache.

It looks like the build on the PPA has been done without libxml2 (for bzrtp, for linphone I guess it's there) so the cache functions are disabled in bzrtp.

Could you try to build and install lib bzrtp on your system with libxml2-dev package installed and check if it solves the problem.

I think Ilya Melnikov which is the maintainer of bzrtp package on the ppa reads this list. If so, Ilya, any chance you could do something for the bzrtp package and libxml2 in the build?



On 22/08/15 00:14, Liviu Andronic wrote:
On 8/21/15, Johan Pascal <address@hidden> wrote:
Thanks Liviu,
the call initiation is missing in the log but this is the interesting
part. The zidcache file shall be created(if missing) at the call
beginning even before the SAS is displayed to you and then updated at
the end of ZRTP negotiation and again when you confirm the SAS. I'm
hoping to find an error message around the creation of file at the call
beginning  as ZRTP switch to cacheless mode when something is wrong with
the first cache access/creation, so successive access are actually

Thanks Johan for looking into this. Here's a second attempt. For the
first call ZRTP was verified by both users. I think now the log is
more complete.

Let me know if further info is needed.


thanks for your help


On 21/08/15 10:47, Liviu Andronic wrote:
Hi Johan,
I'm sending you the logs off-list as it contains private info. I'm
using Ubuntu Trusty, and installed Linphone 3.8.5 from the PPA. The
log is quite long, but I didn't know how to strip it down. Both users
clicked on Verify/Accept in this ZRTP-encrypted call after having
checked the token. And ~/.linphone-zidcache wasn't created on my

Let me know if further info would be useful. Regards,

On Fri, Aug 21, 2015 at 4:34 AM, Johan Pascal <address@hidden>
Hi Liviu,
yes, please send me the log from the linux side. I still can't manage to
reproduce it.



On 20/08/15 09:44, Liviu Andronic wrote:
On Mon, Aug 17, 2015 at 8:59 AM, Liviu Andronic
On Mon, Aug 17, 2015 at 8:13 AM, Simon MORLAT

This is not a known problem at least. Did you make sure that both
clicked on verified button, which is the condition for the trustship
validated ?

Yes, on multiple occasions. I'll check it again, just to make sure,
but thus far with 3.8.x I can't remember the ZRTP cache working right
a single time. I tried removing .linphone-zidcache on my end, and now
I realize that it has *never* been recreated, even if on several
occasions both users clicked on Verified.

I tried this again, this time with the other user using Linphone
Android 2.4.1 (while I'm still using Desktop 3.8.5). We checked the
token, I clicked Verified, the Android user clicked Accept, both had
security feature shown as "locked". Yet the next call using same
devices we were again unverified. I checked, and ~/.linphone-zidcache
was still not recreated on Linux.

Would a log help here?


Can you replicate the issue
if you remove that file?

Thank you and regards,

PS My set-up is 3.8.5 (my machine) and 3.7.x (the other machine).

Best regards,


2015-08-15 23:02 GMT+02:00 Liviu Andronic <address@hidden>:
Dear devels,
In 3.7.x I never had issues with the ZRTP cache: once I verified
with a caller on a given device, for the next call the ZRTP status
automatically set to verified. In 3.8.5 it looks as if the ZRTP
is always corrupt: whether I hit verified or not, every call the
status will default to "not verified".

Is this a regression in the 3.8.x branch?


Do you think you know what math is?
Or what it means to be intelligent?
Think again:

Linphone-developers mailing list

Linphone-developers mailing list

Do you think you know what math is?
Or what it means to be intelligent?
Think again:

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]